Poor AM reception [Archive] - Honda Element Owners Club Forum

: Poor AM reception


rburci
07-09-2003, 02:31 AM
Installed new pioneer head unit and the FM works great but AM is horrible. Any suggestions on a good antenna. The installer has tried several and they are not working.

crazy canadian
07-30-2003, 01:31 AM
AM still exists??!!! Just kidding. :D

jalexgar
12-30-2003, 11:44 PM
"Installed new pioneer head unit and the FM works great but AM is horrible. Any suggestions on a good antenna. The installer has tried several and they are not working."

I installed a panasonic head unit and get good FM, but AM is almost nonexistent. Did you ever find an answer?

eMass
12-30-2003, 11:57 PM
Make sure your installer has connected the power to the antenna. Many do not realize this is necessary.

Kayakin' Dan
12-31-2003, 01:39 AM
Power? Antenna? I am the installer, wanna 'splain?

eMass
12-31-2003, 09:42 AM
The antenna for the E requires a power connection. It is not just a regular antenna it is "amplified". If you were thinking I was saying it is a power antenna that is retractable or something - that's not what I meant, but it does require hook-up of the power antenna lead off the harness which would be used for that purpose in other cars.

Silk
12-31-2003, 11:14 AM
I have an old Pioneer DEH-P5200 and the power antenna wire is blue/white with a female spade clip end. I think Pioneer have changed the harnesses a little since then but you should have no problems locating your power antenna wire. Good luck!