Engine miss upon acceleration - Honda Element Owners Club Forum
      Honda Element Owners Club Forum
Go Back   Honda Element Owners Club Forum > Accessories, Care and Mods > Maintenance and Service

Notices

ElementOwnersClub.com is the premier Honda Element Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 11-17-2012, 12:54 PM   #1
henrybo
EOC Rank: Hydrogen
 
Join Date: Dec 2003
Posts: 12
Engine miss upon acceleration

When I am stopped and hit the accelerator my engine misses badly when I give it gas. My check engine is on most of the time, but not always. I have tightened gas cap, and do not think that is the problem. I had it coded(not at the dealer) ans the code comes up something about the rocker arm. Any ideas? Could it be dirty fuel injectors? Something electrical?
Anybody have any similar problem?
henrybo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-17-2012, 12:55 PM   #2
henrybo
EOC Rank: Hydrogen
 
Join Date: Dec 2003
Posts: 12
Sorry, it's a 2003.
henrybo is offline   Reply With Quote Quick reply to this message
Old 11-17-2012, 01:03 PM   #3
KoolBlue
EOC Rank: Helium
2006 2WD EX-P AT
Other
 
Join Date: May 2006
Location: Toronto Canada
Posts: 172
What are the specific codes that are given?

Without having more information anything we tell you is just guessing.
KoolBlue is offline   Reply With Quote Quick reply to this message
Old 11-17-2012, 03:01 PM   #4
henrybo
EOC Rank: Hydrogen
 
Join Date: Dec 2003
Posts: 12
the code is PO2646
henrybo is offline   Reply With Quote Quick reply to this message
Old 11-17-2012, 03:34 PM   #5
Rick92040
EOC Rank: Oxygen
2008 2WD EX AT
Kiwi Metallic (KM)
 
Join Date: Dec 2009
Location: San Diego area
Posts: 988
I believe you need to replace the vtec pressure switch. Some have had positive results by just taking it apart and cleaning the screen in it.
http://www.elementownersclub.com/for...ressure+switch
Rick92040 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Honda Element Owners Club Forum > Accessories, Care and Mods > Maintenance and Service

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Element Owners Club Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine cuts out under acceleration...help? the_box_rox Problems & Issues 12 07-08-2010 06:10 AM
Engine noise under slight load and slight acceleration chance Maintenance and Service 23 12-29-2009 03:36 PM
Car bucks on load acceleration - engine light on beverlycd Under The Hood / Performance 23 09-22-2009 10:11 AM
*Slight* metallic noise @ idle and acceleration (but not coming from engine) sier Problems & Issues 6 05-02-2005 06:53 PM


All times are GMT -5. The time now is 09:59 PM.



Views and opinions expressed on this forum are not necessarily those held by Autoforums, Inc. or forum management.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.