Heat has me Puzzled ???? - Honda Element Owners Club Forum
      Honda Element Owners Club Forum
Go Back   Honda Element Owners Club Forum > Honda Element > Problems & Issues

Notices

ElementOwnersClub.com is the premier Honda Element Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 01-20-2013, 08:40 AM   #1
J.E.D.
EOC Rank: Hydrogen
2004 4WD EX AT
Nighthawk Black Pearl (NBP)
 
Join Date: Jan 2013
Posts: 3
Heat has me Puzzled ????

Had a decent supply of heat but wasnt as hot as it had been . So I changed the Antifreeze (Honda Antifreeze) and now I have heat on passenger side vent but no heat on driver side and if you close the vent of passenger side it gets warmer on driver side? Any ideas ?
J.E.D. is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-20-2013, 08:52 AM   #2
Rick92040
EOC Rank: Carbon
2008 2WD EX AT
Kiwi Metallic (KM)
 
Join Date: Dec 2009
Location: San Diego area
Posts: 1,008
First.. Does the car's engine warm up as normal? If not change the thermostat.
If it does warm up normal but your not getting warm air try changing the cabin air filter. There are two. You take out one then slide the second over and take it out.
http://www.elementownersclub.com/for...ad.php?t=39619
Rick92040 is offline   Reply With Quote Quick reply to this message
Old 01-20-2013, 08:53 AM   #3
Rick92040
EOC Rank: Carbon
2008 2WD EX AT
Kiwi Metallic (KM)
 
Join Date: Dec 2009
Location: San Diego area
Posts: 1,008
Oh.. And welcome to the forum. There is a "how to" area you will like.
http://www.elementownersclub.com/for..._faq_eoc_howto
Rick92040 is offline   Reply With Quote Quick reply to this message
Old 01-20-2013, 09:21 AM   #4
J.E.D.
EOC Rank: Hydrogen
2004 4WD EX AT
Nighthawk Black Pearl (NBP)
 
Join Date: Jan 2013
Posts: 3
Yes the car heats up like normal,,,and I did pull those filters out last night but havent made it to the store for replacemets but I did start it up last night and the heat or lack of was still doing the same ,,,heat on passenger side but no heat on drivers side ,,,and THX for the welcome mat and looked through the index last night trying to fix this,,,
J.E.D. is offline   Reply With Quote Quick reply to this message
Old 01-20-2013, 06:19 PM   #5
J.E.D.
EOC Rank: Hydrogen
2004 4WD EX AT
Nighthawk Black Pearl (NBP)
 
Join Date: Jan 2013
Posts: 3
Well it wasnt those filters,,,still cold on drivers side but hot on passenger side,,,ANY IDEAS ?,,,those filters being changed did make a difference on the air flow ,,,lots stronger,,,
J.E.D. is offline   Reply With Quote Quick reply to this message
Old 01-21-2013, 08:43 AM   #6
Rick92040
EOC Rank: Carbon
2008 2WD EX AT
Kiwi Metallic (KM)
 
Join Date: Dec 2009
Location: San Diego area
Posts: 1,008
At this point, If it were mine, I would take it to the Honda dealer and ask for a diagnosis. Sorry.
Rick92040 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Honda Element Owners Club Forum > Honda Element > Problems & Issues

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Element Owners Club Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
heat only on passanger side vents- heat core and thermostat already replaced hux Problems & Issues 10 12-20-2008 11:54 PM
No Heat polerpoker Problems & Issues 7 04-19-2008 07:03 AM
How are you doing in this heat? PVR Western Canada Owners+Alaska E Owners! 6 06-12-2007 10:21 PM
no heat danman4246 Problems & Issues 9 02-18-2007 07:29 PM
Heat My E Please! mikie333 Miscellaneous / General Element Discussions 30 12-16-2006 01:01 AM


All times are GMT -5. The time now is 08:10 AM.



Views and opinions expressed on this forum are not necessarily those held by Autoforums, Inc. or forum management.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.