Dash Lights Dimmer Problem - Honda Element Owners Club Forum
      Honda Element Owners Club Forum
Go Back   Honda Element Owners Club Forum > Accessories, Care and Mods > Interior

Notices

ElementOwnersClub.com is the premier Honda Element Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 04-12-2013, 12:05 AM   #1
QbanSC
EOC Rank: Hydrogen
2007 SC 2WD 5AT
Galaxy Gray Metallic (GG)
 
QbanSC's Avatar
 
Join Date: Feb 2009
Location: FLORIDA
Posts: 7
Dash Lights Dimmer Problem

I hope someone within the E community can give me some advice on how to solve an issue I have with my 07 SC. The dash lights (HVAC controls, radio, and shifter) will not dim by using the dimmer knob like they used to; the instrument cluster lights work fine except that do not light up without the key in the ignition. I think all started after a short that occurred while testing the terminals of the shifter light bulb, a fuse went out; I replaced the fuse and the taillight relay which controls the dash lights thinking that could be damaged, but no luck. Any help will be appreciated!!
An Update: 4/12/13 As of now the lights went out completely. After reading some posts in the EOC and some research I think the dimmer circuit board burnt out, therefore the solution would be replace the cluster. I found a refurbished one for a good price, now I have a new issue - how to reset the mileage

Last edited by QbanSC; 04-12-2013 at 10:20 PM. Reason: Update
QbanSC is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-07-2017, 02:59 PM   #2
fez12133
EOC Rank: Hydrogen
2006 4WD LX AT
Magnesium Metallic (MM)
 
Join Date: Jan 2017
Posts: 1
Dimming lights issue

Have a 2006 element and have an issue with the dash lights and the headlights at the same time dimming down low and then coming right back up to full brightness. It does this while idling or while driving it doesn't make a difference which. It doesn't effect the rpms of the engine at all. Its just the lights. Does anyone know why???? Thanks
fez12133 is offline   Reply With Quote Quick reply to this message
Old 01-07-2017, 03:54 PM   #3
dOobersNapz
EOC Rank: Hydrogen
2008 4WD EX MT
Kiwi Metallic (KM)
 
dOobersNapz's Avatar
 
Join Date: Dec 2016
Location: Ohio
Posts: 49
Check the battery terminals, make sure they're nice and tight, and not corroded. Make a run to the auto parts store and have the battery and alternator tested. If all that checks out, make sure the lead from the alternator to the battery is up to snuff as well.
dOobersNapz is offline   Reply With Quote Quick reply to this message
 
Old 01-09-2017, 09:43 AM   #4
ramblerdan
EOC Rank: Crankypants
2004 4WD EXS MT
Fiji Blue Pearl (FBP)
 
ramblerdan's Avatar
 
Join Date: Apr 2004
Location: Saratoga, N.Y.
Posts: 14,283
Welcome, Fez12133.

+1 on cleaning and resecuring cables—especially grounds—on both ends. In addition to the battery negative cable, check and service the chassis-to-transmission strap and this cable over on the passenger's side of the engine bay.

If you establish the soundness of connections and the problem persists, you might have a bad electronic load detector (aka voltage regulator) or, less likely, alternator. A thread-title search for keyword "ELD" will return relevant threads.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by ramblerdan; 01-09-2017 at 09:56 AM.
ramblerdan is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Honda Element Owners Club Forum > Accessories, Care and Mods > Interior

Tags
dash lights , dimmer , dimming interior lights

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Element Owners Club Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Model Year
What year is your E?
Model
What model is your E?
Color
What color is your E?
Can you spell?
What letter in the alphabet is the fifth character of the word "Honda Element"
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Dash Lights and Running Lights supradave Problems & Issues 1 02-17-2013 11:35 AM
Dash problem Please HELP!!!! Dchino524 Problems & Issues 13 09-30-2012 09:53 PM
fuses - parking lights/dash lights 77civic Maintenance and Service 1 10-27-2008 11:40 AM
Dash lights and parking lights out (= blown fuse) mbaha Problems & Issues 14 10-20-2008 12:05 AM
parking lights and dash lights on when you push the brake pedal cpaul10 Problems & Issues 6 06-24-2005 05:42 PM


All times are GMT -5. The time now is 03:36 PM.



Views and opinions expressed on this forum are not necessarily those held by Autoforums, Inc. or forum management.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.