smoke blowing from AC vent? - Honda Element Owners Club Forum
      Honda Element Owners Club Forum
Go Back   Honda Element Owners Club Forum > Honda Element > Problems & Issues

Notices

ElementOwnersClub.com is the premier Honda Element Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-20-2007, 05:10 PM   #1
mizsydney
EOC Rank: Helium
2005 4WD EX
Rallye Red (RR)
 
mizsydney's Avatar
 
Join Date: Mar 2005
Location: Central CA
Posts: 108
smoke blowing from AC vent?

this was so weird -

we were driving up a freeway onramp and suddenly noticed an odd burnt matches/perm solution/stinky burny smell in the car. it was still cool outside so the AC fan may have been on very low or may have been off - didn't notice. the vent setting was still Max AC, left from yesterday's 94 degrees.

when we both noticed the smell, I turned up the fan speed to try to shut out (or clear out) the smell. (Max AC defaults to Recirculate, not fresh air. but it was pre-coffee early morning and I hadn't quite figured the details out yet.)

when the fan speed increased, smoke came out of the center dash vents. sort of wispy, but definitely smoke with the same burnt matches smell, actually blowing thru my beloved's vents. then it was gone. maybe a puffy cloud about a foot square? before it stopped and dissipated. (fan kept running, smoke stopped, just to be clear.)

after the initial "are my eyes deceiving me?" stunned stupid shock, I turned the AC off right away.

no dash warning lights, nothing obvious in the engine compartment. if I didn't have a live witness in the car, I'd doubt myself.


I searched the EOC forums and found some references to moist air & the AC creating a mist, but no one mentioned any smell and this seemed to have a definite burny odor to it. and it wasn't especially damp, or cool, or warm. maybe 68-70? 60% humidity? (it's a dry heat, here. "we are just so lucky" (monotone) - unless it is 112. ick.)

has anyone else possibly experienced this? we left the car parked for an hour or so at my appointment, and then ran the AC after that, no smell, worked fine.

AC was never smelly before in any way (except that odd musty smell you get in every car for a moment when you turn off the AC but leave the fan on and it switches to vent)...

the only thing I can POSSIBLY imagine is that DH had just chirped the tires at a broken stoplight just before we got on the onramp, and maybe there was some smoke in the engine compartment that got sucked in when I turned the fan up? we had traveled maybe a block plus the onramp between stoplight and smoke, but we were moving pretty slowly, there was a slowpoke in front of us (hence the "need" to chirp the tires).

yes, I think I am really reaching with the tire chirping. but what else could it be?

just wanted to run this experience past the 20,000 E owners on EOC before I go provide humor for the dealership. they already don't seem to think much of the E. and mysterious smoke? from the dash? those E owners are certifiable!

thanks for your input!
mizsydney is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-20-2007, 05:23 PM   #2
zoidman
EOC Rank: Hydrogen
2007 2WD EX AT
Tango Red Pearl (TRP)
 
zoidman's Avatar
 
Join Date: Aug 2007
Location: Milky Way - Local Group - Earth
Posts: 80
I won't fool around and would get it checked out by the dealer ASAP.

To put it simply:

Fire Bad.
Fire in Car, Very Bad.
Fire in Car while Moving, VERY BAD!
zoidman is offline   Reply With Quote Quick reply to this message
Old 08-20-2007, 05:42 PM   #3
SDJ22
EOC Rank: Hydrogen
2005 4WD EX MT
Rallye Red (RR)
 
SDJ22's Avatar
 
Join Date: Jul 2007
Location: Michigan
Posts: 15
Rubber burning has a distinctive smell. "burning matches" would have a different smell. Just a suggestion, but pull your cabin filters and see if there appears to be any rodent damage to them or maybe some kleenex type material in the blower case. The blower motor power transistor is mounted in the case near the blower motor and if a rodent is nesting there, it could get hot enough to burn, particularly at low blower speeds.
SDJ22 is offline   Reply With Quote Quick reply to this message
Old 09-16-2007, 12:07 PM   #4
voltagesls
EOC Rank: Hydrogen
 
Join Date: Mar 2006
Posts: 13
Red face ive had a similar smell

Your not the only one, ive had that same smell and little smoke cloud about 5 times now. I currently have 118k on my 03 element. don't know why this has happened and Ive had my regular maintenance done at a honda dealership. I usually forget about that issue when I'm there so i've never brought it up. Im not to worried about it. All my fluids are changed regularly so whatever happens happens.. i'm not worried about it (very strange though)
voltagesls is offline   Reply With Quote Quick reply to this message
Old 09-16-2007, 12:28 PM   #5
wastedonanime
EOC Rank: Carbon
2006 4WD EX-P MT
Nighthawk Black Pearl (NBP)
 
wastedonanime's Avatar
 
Join Date: Aug 2006
Location: Sunderland, MA (UMass Amherst)
Posts: 1,668
Send a message via AIM to wastedonanime
I've had this happen several times on my Volvo 850. However, the car was 8-10 years old when it did happen and it only happened on random occasions. Usually, turning it off and waiting a minute would alleviate the problem, but I never found out why it happened or what it was.
__________________

"The Black Sheep"

2006 EX-P "SC-X" Project
[OEM Accessories : SC Part Swaps : Performance & Handling : 1800w Audio/Video System : DIY Modifications]

Thinking about HID's? Consider an SC Front End Conversion for HID-required projector headlights.
wastedonanime is offline   Reply With Quote Quick reply to this message
Old 09-19-2007, 12:46 AM   #6
ep_404349
EOC Rank: Hydrogen
2005 4WD EX AT
Magnesium Metallic (MM)
 
Join Date: Sep 2007
Posts: 3
hey I just came back from yosemite this past weekend and on the way home, I got that same smokey thing from my AC vent also... but it was from the passenger side only... I have an '05 EX 4WD...
ep_404349 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Honda Element Owners Club Forum > Honda Element > Problems & Issues

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Element Owners Club Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cleaning smoke build-up off inside windsheild sier Interior 22 02-25-2008 08:31 AM
AC problem mikesafish Problems & Issues 12 05-28-2007 08:55 AM
AC and Windshield defrost ewe_2 Problems & Issues 2 04-18-2007 03:55 PM
Broken AC Vent Cosmic Debris Interior 2 09-29-2005 05:31 PM
What's up with Honda blowing smoke? Doubro Shoppin' and Test Drivin' 28 02-28-2004 11:43 PM


All times are GMT -5. The time now is 04:07 AM.



Views and opinions expressed on this forum are not necessarily those held by Autoforums, Inc. or forum management.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.