Honda Element Owners Club banner

cel

  1. Problems & Issues
    I have a 2003 E EX that I bought used about 6 months ago at 136k miles. About a month into driving it, cruising down the highway, the check engine light turned on. A friend said that I should tighten the gas cap. I did and it stayed on. I took it into the local JiffyLube a couple days later and...
  2. Problems & Issues
    Hello all! Long time lurker, first time poster. Have utilized a lot of the helpful tips and forum posts here to troubleshoot problems I've encountered with my Element, but I'm feeling pretty disheartened about all of the repairs that have been needed since purchasing the vehicle a year and a...
  3. Problems & Issues
    I have a 2004 4WD EX with 182,000 miles. I've started having an issue where the CEL comes on so I've taken it to the dealer to have it checked out. The first time this happened, they told me that the engine oil hadn't been changed in a while (I have changed it religiously since buying the car...
  4. Problems & Issues
    Can a faulty IAT sensor cause a misfire? Hey all, first post here! My CEL came on a couple of weeks ago and I've been struggling to fix it permanently. I'm getting P0113 and P0302. I've done exhaustive work trying to figure out the cause of my misfire. Checked my coils, fuel injectors, and...
  5. Problems & Issues
    Hi all - Bought an E a few months ago. Found a 2003 DX with low k's and have been loving it for my little surf and ski gear pod. Check engine light came on recently. I ordered a Veepeak bluetooth OBD2 scanner from Amazon. I downloaded Torque Pro for my phone and scanned the codes. Came up with...
  6. Problems & Issues
    Hi everyone: The lights in the instrument gauges stay on even after I turn off the engine, remove the key, and lock the car. The dome light fades out (like it is supposed to), and the instrument gauge lights START to fade out, but then, before they go fully black, they jump back to full...
  7. Problems & Issues
    I haven't made any changes to the car in the past 2 weeks or so but I've gotten a CEL today when getting on the highway. Later, when accelerating hard to make a light, "maint req'd" and hand "brake" lights went on and the car started bogging a bit as I stopped shifting. Under normal driving it...
  8. Problems & Issues
    Well my dear EOC friends I have had my first problem with my Element after 96,000 miles. While driving down the road the other day my malfunction indicator lamp came on. I instantly thought it was my gas cap so I removed and reinstalled it and took off again but I started cutting out and losing...
Top