Honda Element Owners Club banner
1 - 15 of 15 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter · #5 · (Edited)
Dumb me, it's the ("malfunction indicator lamp") !!!!

Yeah, (today) it skips a few times and it doesn't idle now... weird things happening

I'll go check it out right now, maybe a bulb is out.....?Huh ?
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #6 ·
Page 66 told me to go to Page 193 in my 2004 owner's manual....and the gas cap isn't loose.

The explanation (P193) doesn't sound good "Emissions" Duh!!!???

We don't have a emissions law here in Florida any more and I've been running a K&N intake for 2 yrs.

ANY ideas helpful.
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #8 ·
I guess I'll have to wait on the next warning light failure, I dis-connected the battery grd cable for an hour and the light went away.

Can auto-zone (or the Honda dealer) still pull the codes with the light off .......??
 

·
Registered
Joined
·
178 Posts
An erratic idle like this is caused by a dirty IAC valve located on the lower side of the throttle body. You may want to remove the throttle body to locate the IAC valve then clean it with brake cleaner. The reason I say clean it with brake cleaner is carb cleaner leaves a residue while brake cleaner dries clean and clear. A good cleaning should be all that is required to stop your headache.
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #15 ·
Fixed

I pulled the TB and cleaned up to correct the throttle butter-fly that was sticking at times, (while there) I cleaned up the 3 area's in the IC valve.

It now runs great, it's fixed.

Thanks All.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top