Honda Element Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter #1
I just picked up an 08 5-spd and put a couple of hundred miles on it. I noticed that there is a "click-click" when using the clutch while shifting. It sounds like a switch of some sort. I noticed that there is a slight delay with the RPMs coming down between shifts.

A friend of mine had an 07 or 08 SI that did this and I guess it was put into place to help people who aren't familiar 5/6spd cars or fuel mileage. From what I understand, Honda released a software update that remedied the hang. Does anyone know if there is such an update for the Element?

Thanks
 

·
Registered
Joined
·
42 Posts
I just picked up an 08 5-spd and put a couple of hundred miles on it. I noticed that there is a "click-click" when using the clutch while shifting. It sounds like a switch of some sort. I noticed that there is a slight delay with the RPMs coming down between shifts.

A friend of mine had an 07 or 08 SI that did this and I guess it was put into place to help people who aren't familiar 5/6spd cars or fuel mileage. From what I understand, Honda released a software update that remedied the hang. Does anyone know if there is such an update for the Element?

Thanks
I've got a Japanese truck with a manual transmission, and there is also a click-click every time I use the clutch while shifting. I've never dug into it...to tell you the truth, I made an assumption it was the clutch safety switch...so, maybe that is what is making the click sound on yours?
 
1 - 3 of 3 Posts
Top