Honda Element Owners Club banner

21 - 40 of 52 Posts

·
Registered
Joined
·
3 Posts
Metra 70-7863 Amplifier Retention Wire Harness for 2003-2011 Honda Element
Link to the wire harness:
Amazon.com: Metra 70-7863 Amplifier Retention Wire Harness for 2003-2011 Honda Element: Car Electronics

My tweeters work just fine with this stereo. The EX has a separate amp tucked inside the dash that feeds the tweeters and sub.
What did you do to make the subwoofer work? I used the metraonline 70-7863 kit and plugged "AUX OUT" into the harness subwoofer. No detectable sound from the subwoofer.

Incidentally, I drilled 4 holes in the inside lip of the factory bezel. Wouldn't be able to see the mod if the factory radio were put back in. And I used the factory screws to hold the new unit onto the bezel, just kind of centered it. (see pics)

204112
204113
204114


204111
 

Attachments

·
Registered
Joined
·
3 Posts
BY THE WAY here is a rooted ROM that may work for this device: ROM / Firmware/ Brick Recovery for 7" Android Head Unit AC8227l YT9217 YT9218 1/16GB

Found the subwoofer pin! (quote from XDA)
"Subwoofer output Pin:
The default AUX_out pins are for mid range audio and is controlled by Mid slider in the mixer. The subwoofer output is on another pin (See Picture).
it is easy to remove one of the AUX_out pin and install it at the Sub output. this pin is controlled by Subw slider in the audio mixer."
204115
 

·
Registered
Joined
·
3 Posts
UPDATE: I got some 28 AWG breadboard jumpers from amazon and these were very handy, enabled me to hook up the subwoofer, which works great now, (I have the subwoofer volume set to max in the unit's equalizer, and everything else set to 50%) and the jumpers also let me hook up to the plug with the AUX in / etc pins, so there was minimal additional wiring needed. Subwoofer works as verified by unplugging all the other speakers.

Have had this stereo for weeks now and am getting to like it more and more. However my launcher's volume control gesture doesn't actually adjust the system volume. So will have to try another launcher I guess. Also I wish it had a mute button but if I get a working launcher this shouldn't be an issue.
 

·
Registered
Joined
·
9 Posts
I'm tempted to try one of these cheap 2 din units. I'd rather not block the vents or the climate controls. And I prefer to have some analog buttons on the deck. Call me an old man..but I dig analog buttons. I'm just worried at how much the os will be a POS that the screen will...accidentally shatter when my foot...accidentally hits it.

 

·
Registered
Joined
·
35 Posts
@grilledcheese @Noah B @whipperwhip does this support any backup cameras?
yes it comes with a backup camera and all necessary wiring! you wire into your reverse lights in the back, and the camera comes on

I like the look of the larger screen but I really want to have Apple CarPlay. I know it would be much more expensive but has anyone tried the Jensen CAR1000 or the Alpine Halo9 ILX-F259? I’m curious if either of these units would block the A/C vents.
i read on xdaforums this hikity unit supports apple carplay with a rooted rom. i have no desire for this, but i think its possible!
 

·
Registered
Joined
·
35 Posts
UPDATE: I got some 28 AWG breadboard jumpers from amazon and these were very handy, enabled me to hook up the subwoofer, which works great now, (I have the subwoofer volume set to max in the unit's equalizer, and everything else set to 50%) and the jumpers also let me hook up to the plug with the AUX in / etc pins, so there was minimal additional wiring needed. Subwoofer works as verified by unplugging all the other speakers.

Have had this stereo for weeks now and am getting to like it more and more. However my launcher's volume control gesture doesn't actually adjust the system volume. So will have to try another launcher I guess. Also I wish it had a mute button but if I get a working launcher this shouldn't be an issue.
so just one of those breadboard wires plugged into that single subw pin wired to the sub made for correct sub output?
i just ordered a rockville 8" powered sub/amp combo would love to wire it correctly!
 

·
Registered
Joined
·
2 Posts
I have a lot of experience with these Android head units, the sound quality will be a dip from a Pioneer, but they have improved over the years. the newest Joying and Dasaita are probably pretty close in sound quality.

I have used Seicane, Joying, Dasaita, and I have tried Android Auto on Sony units and an Alpine. I prefer the Android head units, but there are nice features of Android Auto as well. It is all about how you plan to use it and the features you are looking for. also understanding you will need to tinker with it, and it won't be as smooth and straight forward as an Android Auto unit.
 

·
Registered
Joined
·
1 Posts
Li'l help?
New here. Recently picked up an 03 EX. I just received my head unit, and purchased the above mentioned harness. I have 5 rca's coming from the Element, but only two rca outputs at the head unit harness. Did I receive the incorrect head unit harness? My logic sees this as only a two channel output. The unit itself is identical to the one pictured above...



Thanks in advance for any suggestions.

Update, if anyone cares...clipped and soldered high level outputs in place of the RCAs from tablet harness. Got all speakers to work, but the head unit is crap and the screen freezes up after a couple of minutes of being turned on. Rear of component gets very hot, then touch screen stops working. Sometimes when turned on the sample .WAV file will play and cannot be switched to Bluetooth option. Gonna send it back and opt for a Hikity instead. We'll see...

When it did play, the sound quality was actually pretty good.

Man, this has to be the quietest Forum I've ever visited...everyone must be camping...:confused:
 

·
Registered
Joined
·
24 Posts
Is this still the version and brand to trust?

Do steering wheel controls work with this Android unit?
 

·
Premium Member
2007 Element EX TRP
Joined
·
2,529 Posts
The head unit upgrade looks AWESOME!! Having said that, you spent all this time/money on this upgrade, but still retain the stock shifter boot??!! It's and easy, and GREAT looking upgrade!! See posts under "leather shift boot" for more pics/ideas.
 

·
Registered
Joined
·
3 Posts
I just finished installing mine. I modified some mirror clips and screwed them into the existing face plate to support the bottom. Some velcro tabs on the top corners so I can pull this on and off. I like the unit and agree that it really looks great in the Element. It boots and connects fast, and is very responsive. The sound is pretty good but I am having an issue with the back-up camera. It has power but won't trigger the display. And while the unit is listed as supporting subwoofers, the harness is not wired for it. The pin is there on the unit. Still wrapping my head around solving this.
BY THE WAY here is a rooted ROM that may work for this device: ROM / Firmware/ Brick Recovery for 7" Android Head Unit AC8227l YT9217 YT9218 1/16GB

Found the subwoofer pin! (quote from XDA)
"Subwoofer output Pin:
The default AUX_out pins are for mid range audio and is controlled by Mid slider in the mixer. The subwoofer output is on another pin (See Picture).
it is easy to remove one of the AUX_out pin and install it at the Sub output. this pin is controlled by Subw slider in the audio mixer."
View attachment 204115
How would you do that. I bought the Metra harness and the subwoofer adapter has an RCA Male plug. Wouldn't that mean there is a + and -. Pin A16 (which you showed) is that the +? And what about the negative?
 

·
Registered
Joined
·
51 Posts
Li'l help?
New here. Recently picked up an 03 EX. I just received my head unit, and purchased the above mentioned harness. I have 5 rca's coming from the Element, but only two rca outputs at the head unit harness. Did I receive the incorrect head unit harness? My logic sees this as only a two channel output. The unit itself is identical to the one pictured above...



Thanks in advance for any suggestions.

Update, if anyone cares...clipped and soldered high level outputs in place of the RCAs from tablet harness. Got all speakers to work, but the head unit is crap and the screen freezes up after a couple of minutes of being turned on. Rear of component gets very hot, then touch screen stops working. Sometimes when turned on the sample .WAV file will play and cannot be switched to Bluetooth option. Gonna send it back and opt for a Hikity instead. We'll see...

When it did play, the sound quality was actually pretty good.

Man, this has to be the quietest Forum I've ever visited...everyone must be camping...:confused:
Any updates on this?

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
1 Posts
Any updates on this?

Sent from my SM-G970U using Tapatalk
I'll be hooking all this up in the morning. I am going to try running the (only) RCA 2 channel outputs from the head unit out and split them right (Front R and Rear R) and left (Front L and Rear L). Should work but I'll loose fade control but have balance. If this does not work I have hi/low level converters for the head unit speaker outs up next. I have the wireless Apple CarPlay 10" Android unit. I have already installed one of the yesterday in an 09 Vibe/Matrix.
 

·
Registered
Joined
·
51 Posts
I'll be hooking all this up in the morning. I am going to try running the (only) RCA 2 channel outputs from the head unit out and split them right (Front R and Rear R) and left (Front L and Rear L). Should work but I'll loose fade control but have balance. If this does not work I have hi/low level converters for the head unit speaker outs up next. I have the wireless Apple CarPlay 10" Android unit. I have already installed one of the yesterday in an 09 Vibe/Matrix.
How did this work out?

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
1 Posts
Hi, I installed this on my 2005 EX and love it... but I'm having serious alternator whine issues. If there's no music playing there's a high pitched whining noise from all of my speakers when the car is on. When the car is off, I can hear feedback through the speakers until the unit powers down. I tried a ground loop isolator but it made my audio sound like it was coming through a cell phone speaker. Any ideas on what I can do?

Also if anyone's interested, I have wireless Apple CarPlay from my iPhone via this dongle I bought on amazon: "Carlinkit Wireless Carplay Dongle". Works great, just need to update it using their instructions once it arrives.
 
21 - 40 of 52 Posts
Top