Honda Element Owners Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought a 2007 LX because I got a good deal and like the dark bottom panels. Then I bought a 2005 Element radio which has the AUX input. The original OEM radio is very low end and simple. It connects only to the main 20-pin plug. When I plug in the 2005 radio (and enter the security code) it works, but has almost no power. CD works and radio works, but max volume is barely audible.

Any experience out there? Is my LX missing an amp or something? I haven't even gotten to wiring the AUX yet.
 

·
..
Joined
·
12,178 Posts
I bought a 2007 LX because I got a good deal and like the dark bottom panels. Then I bought a 2005 Element radio which has the AUX input. The original OEM radio is very low end and simple. It connects only to the main 20-pin plug. When I plug in the 2005 radio (and enter the security code) it works, but has almost no power. CD works and radio works, but max volume is barely audible.

Any experience out there? Is my LX missing an amp or something? I haven't even gotten to wiring the AUX yet.


The Ex radio has an external amp.
 

·
Registered
Joined
·
10,181 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #8
2007 - 2005 Radio Problem

You guys are great! My first post and I've gotten more help than I was able to find Googling for 2 hours. Nighthawk, schematics are great. I'll probably go with a good aftermarket unit with built-in amps and AUX in. Only one harness match to make that way.

Thanx............
 
1 - 8 of 8 Posts
Top