Honda Element Owners Club banner
1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Well here it is.. I just took my E into the dealership to have it looked at because my A/C was not blowing cold air. They call me back later in the day and tell me that the condenser has a hole in it and that it is not covered under warranty, because it was damaged and not a defect. I think the design in itself is a defect, but I have a meeting with a Honda Rep tomorrow to plead my case that it should be covered under warranty, if its not covered then they say it will run about $700.00 to fix. I am pretty upset about this and dont really want to or try to avoid every little thing on the road that may cause this. I also brought it in for a rocking drivers seat, for the third time, hopefully it will be fixed right this time. Has anyone run into this problem with the condenser at all? Thanks for your time.
 

·
Registered
Joined
·
299 Posts
That's what I did the $1.50 Home Depot grill for, to prevent that kind of problem. The E has way more open space in front of the condenser than any vehicle I've ever owned. I would argue that design is what makes the E prone to condenser damage.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
I just got back from the dealership and I have good news. I lucked out and didnt even have to talk to the Honda Rep about it. When I got there the service tech said that they were going to fix it as a good will gesture. So now it will be fixed and be done by tomorrow.
 

·
Registered
Joined
·
359 Posts
Well I suggest you put the grill in. I did it the second day I got her.

Here's a pic

 

·
Registered
Joined
·
5 Posts
My E has about 3,000 miles on it now and I love it. However, the A/C has started acting up. It works fine but for the past few days when I take a left hand turn the blower, fan, or whatever makes a screeching noise and condensate (water) spills onto the floor in the foot well of the passenger side. It leaks on the driver's side too but not as badly. Anybody else have this problem? I'm calling the dealer today.
 

·
Registered
Joined
·
3,278 Posts
Could be the drain hose is plugged up, so all the condensation isn't draining and the screetching noise is due to water in the fan housing?

-brendan
 

·
Registered
Joined
·
5 Posts
Thank you brendan it is the hose being clogged (I think). I spoke to a dealer and he told me I could stop by or try blowing compressed air up the hose, which I did. During my search for the hose I got under the flooring on the passenger side and the padding underneath was soaked. Have to take it in to the dealer now and see what happens. Didn't someone else on the boards get a moldy smell from this same problem? Thanks for your help.
 

·
Registered
Joined
·
3,278 Posts
Same thing happened on my old Colt a long time ago. And yes, it starts smelling nasty if not dried out quickly.

I seem to recall seeing another post bringing up that issue, yes.

-brendan
 
1 - 8 of 8 Posts
Top