Honda Element Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Just got a 2005 E and everything was working great then basically at the same time the A/C stopped blowing cold while driving, it was very difficult to start and the CEL came on. Took it to the Honda dealer for a code 2646 and to get the A/C checked. They vac'd and charged the A/C, but it is still only blowing cold while sitting still and idling. For the 2646 Code they told me that the engine was bad and that it had been run low on oil thus stretching the timing chain causing an itermittant timing jump. The recommendation was to buy a new motor. I saw a lot of post about the VTech Selenoid so I just changed it and it seems to run OK, but I'm worried about the timing issue. Any thoughts on these 2 problems?
 

·
Moderatorium
Joined
·
6,408 Posts
A/C problem: probably overpressure, which shuts the compressor off just like an underpressure. If somebody just serviced it then they could have easily overfilled it. Get an independent A/C shop to put their tree on it.

P2646: the dealer actually told you it could be a stretched timing chain? Intermittent timing jump? And you need a new motor? For a 2646? Pish-posh. What you need is a new dealer - they were blowing smoke up your skirt, big time.

Get the A/C checked for overfill and things ought to be golden.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Mike.
I am taking it back in to have the A/C rechecked.

For the 2646 Issue: They mentioned evidence of low oil in the past. I replaced the Vtec selenoid and it seemed ok, but everytime I cold start, it has to crank for a while then runs rough for a few seconds. Each start after that is perfect until its a cold start again. CEL popped on again but I don't know what the new code is yet.
 
1 - 3 of 3 Posts
Top