Honda Element Owners Club banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all,

I've read a few comments on here pertaining to the A/C problems in some E's, but nothing definitive.

Here's my issue: I'm driving on the highway this past Thursday, and notice the A/C is not pumping out cold air anymore...just blowing fresh air in, so I turn it off. All of a sudden, it sounds like the world is ending, so quickly I turn the air back on and.....yep...silence. Weird right? Once this noise starts, it won't stop until I turn the air back on. I've had a mechanic 'take a quick peek,' but without further inspection, he could only tell me that my a/c is constantly on, but not working properly, and that the pressure valve probably blew and released the refrigerant. So...to my questions:

1) Does anyone know of any TSBs or recalls on this specific problem?
2) Does anyone know exactly what this problem is?
3) Is this something that Honda will fix without astronomical cost to me?

Any help is obviously appreciated. My E has about 150,000 kms on it...or 93,000 miles for those of you south of the border.

Thanks in advance.
 

·
Registered
Joined
·
1,911 Posts
Without looking at it its hard to say what really happened. You need to find someone in your area that knows AC repair so they can tell you what happened. I have never heard the pressure valve going off when the unit is shut off only when its turned on and has been overfilled and then it sounds like you blew out a tire and will get a vapor cloud out from under the hood for a few seconds and the valve will close if the E even has that type of unit and if not it will discharge the whole load of freon. There has been some compressor and clutch issues so that would something to look at.
 
1 - 2 of 2 Posts
Top