Honda Element Owners Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #1
I'm driving my new 2010 I just picked up onSunday and I'll be darned if the AC don't work in it now! It was only like 80 today tops and I kept waiting for the air coming out to get colder than the air around me. Never did. Bummer. Now I gotta take it 25 miles back to the dealer on Friday and wait around for it to be fixed.
 

·
Registered
Joined
·
1,911 Posts
And??? Its definitely under warranty and hopefully doesn't have a leak.
 

·
Registered
Joined
·
3,060 Posts
I'm waiting to hear if he picked up some A/C core damage from a stone on that 25 mile trip home from the dealer. He might've set a new record.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #4
And I've never had a major item like that be wrong with a vehicle right outta the box and yeah it will be repaired under warranty. And AC is kinda important in AZ :) SO it goes in tomorrow morning. We'll see what it is. I can hear the ac hissing wheN I turn it on but no cold air :(
 

·
Registered
Joined
·
1,911 Posts
If you hear it hissing it sounds like the blend door is not moving.
 

·
Registered
Joined
·
153 Posts
Discussion Starter #8
It's fixed! It was an O-ring that got crimped so they replaced and now I need to wear a parka inside my E even when the air is on the lowest setting. Yeah! The dealersip was very nice and got the job done quick and right.
 

·
Registered
Joined
·
1,235 Posts
Cool that it all worked out for you.
 
1 - 9 of 9 Posts
Top