Honda Element Owners Club banner
1 - 20 of 21 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
hi ...

it's been a while since i've had the time to visit here, but i thought i would share the following:

10,900 miles and the check engine light comes on. I tighten the fuel cap, and the light eventually goes off (within 30 miles). Then the light comes back on. I take it into the dealership, and they say it's a bad catalytic converter (covered by the warrenty).
 

·
Registered
Joined
·
211 Posts
I sometimes have a bad rotten egg smell when I pull in the garage. It does not to it all the time though. Anyone else?
 

·
Registered
Joined
·
33 Posts
[quote:c2c89c92b9="pookSter"]I sometimes have a bad rotten egg smell when I pull in the garage. It does not to it all the time though. Anyone else?[/quote:c2c89c92b9]

No Way! My E is a Low Emissions Vehicle (LEV), so the exhaust is more pure than the fresh Houston air.
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #5 ·
[quote:e5ab2586d1="RML"]Were there any other signs?[/quote:e5ab2586d1]

Nope. Nothing. I've read (from this forum) that running the gas tank too close to empty could damage the catalytic converter, but I've never let it get below 3 or so gallons (I've never put in more than 12.5 gallons, and I regularly only have to put in 11.x), so I doubt that was the cause ...

They won't be able to replace the CC until sometime next week (waiting for the part), and I haven't noticed anything different about the E at all, aside from the Check Engine light coming on.
 

·
Registered
Joined
·
4 Posts
We also have been getting a rotten egg sulphur smell at times from our Element, but otherwise runs fine.

[quote:cce6b73c53="pookSter"]I sometimes have a bad rotten egg smell when I pull in the garage. It does not to it all the time though. Anyone else?[/quote:cce6b73c53]
 

·
Registered
Joined
·
273 Posts
i have my E hooked up to a network... ever since i went on line with it, (over 6000 mi.),,, its told me my catalyst efficiency is below threshold, (bank 1)... taking it in this thurs. for some service bullitens and diagnostics... :mrgreen:
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #10 ·
I hope it's a wireless network ...
 

·
Registered
Joined
·
273 Posts
>>>>Whahuh? NETWORK?<<<<

yea, network... card that monitors engine performance, and tracks vehicle... i can find my E anywhere in north america,,, even tells me if its stopped or running... :mrgreen:
nice extra,,, no more california smog tests... network sends info directly to state.... 8)
 

·
Registered
Joined
·
273 Posts
>>>>Not good. Well, has anyone else had this problem?<<<<

yeah,,, took E in today,,, bad converter... :evil: said part will be in tommorow... :mrgreen:
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #14 ·
just got mine replaced yesterday -- it was the first one that the dealership had to do (so the service guy said), but they couldn't find anything wrong with it (other than the computer said that something was wrong with it). They are sending it back to Honda for evaluation, and the service guy said that he would expect more of these to start showing up ...
 

·
Registered
Joined
·
273 Posts
Hmmmmmmm, same problem as puppy... :shock: lets see how this plays out.... :twisted:
 

·
Registered
Joined
·
106 Posts
If I drive more than 5 minutes or so I get the sulfer smell when I turn it off and get out of the car. Not good at all.
While I don't have the "check engine" light yet, I'm going in for my oil change next week, gonna have them check it out.

but hey, no problems with the windshield....
 

·
Registered
Joined
·
51 Posts
I haven't smelled (spelling?) anything recently, but a few times during the first month I could smell something aweful at the back of the vehicle. Stuck my nose down near the exhaust and it didn't seem to come from there, and went away quickly. Since it hasn't come back, or maybe I'm just not noticing it now, I haven't worried. Are you all saying I should have the cat checked out?
 
1 - 20 of 21 Posts
Top