Honda Element Owners Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1 (Edited)
I've decided to return the CD5030 and get the Kenwood X994. The Kenwood showed up today but I haven't installed it yet. Soldered the harnesses together and the Pac module. Will install tomorrow and have pics of both HU in the dash.

The 5030 was a pretty good deck but had too many glitches. The 7 band parametric EQ with 3 different frequency option per band is excellent. The OEL display was really nice. I'm definitely going to miss that. User interface was simple but is a little sluggish as you move around it.

The Kenwood, I'm already impressed with it. The buttons don't fee as cheap as the 5030. They got rid of the joystick from the x993. No more joysticks. Just one push button knob and 4 surrounding buttons. Hopefully the LCD display will be adequate and not get washed out by sun light like the previous model.

Oh, the Kenwood didn't come with a case for the faceplate. Just a bag. Kinda sucks.

Hopefully I'll get this installed tomorrow.
 

·
Registered
Joined
·
140 Posts
Discussion Starter #2
Eclipse CD5030




Kenwood x994






The Kenwood is not hard to use at all. The DSP's not too bad! Even with only a 5 band graphic eq I was able to dial in a good sound. The bluetooth works great, downloads the phonebook in less than 5 seconds. Accessing the phonebook is slow. The variable color for display and buttons are a plus to match the interior. USB drive is quick. The Pac module was really easy to install/program. The downsides are you have to hold the steering button a tad longer than OEM and I've lost seeking forward.

The only thing I hate is the LCD screen. It fades out when viewed from wider angles. Really miss the OEL display. There's no summing of the subwoofer output like the Eclipse so the subwoofer output is much lower than the Eclipse. I have the sub level at max and it's outputting the same as the Eclipse at -1 to 0. Might have to buy a y adapter.

 

·
Registered
Joined
·
140 Posts
Discussion Starter #4
I called in to Crutchfield last week to ask about it and they had just gotten a shipment of them in. It wasn't on their website yet but they still shipped one out to me. They're officially available on Crutchfield right now though.
 

·
Registered
Joined
·
3 Posts
Just ordered one!!!!

I called into crutchfield earlier today at about noon and asked about a head unit. i was originally looking at the kenwood kdc x993 but the advisor headed me towards the x994. can't wait till it comes in... should come in on thursday.
 

·
Registered
Joined
·
42 Posts
Tao - Did you change your speakers as well? I am looking to upgrade the stock speakers in my E, but having a hard time deciding.
 

·
Registered
Joined
·
140 Posts
Discussion Starter #8
Yep, same here as Brian. Bought a pair of Polk db651s (shallow) to replace the fronts. I didn't notice that drastic of an improvement but they were playing off the OEM head unit at first. Now with the new headunit and the speakers broken in it's sounding pretty nice in the E. They'll sound a lot better with an aftermarket amp.

I had no intention of doing much with the sound system in the Element... but after the HU and the speakers... oh it's on. Gonna wait until spring to decide how I'm going to do this. I really want a JL 8w7 in a custom enclosure up front or like how Yoda has his sub.

But yeah the polks aren't bad for around 50-60 bucks.
 

·
Registered
Joined
·
3 Posts
same here

well actually I had polk audio 6.5 speakers in my car until i totaled it earlier this month. but i had a head unit from 2004. the polk was relatively new though i ordered them last year.
Tao did you put a review on youtube or something??? i would love to see it.
 

·
Registered
Joined
·
3 Posts
Kenwood x994 problem

Tao after installing did you have any issues with the cd player or ipod playback. mine would work fine up until like the fourth or fifth time starting the car and then the cd player would just say 'reading" and the disc wouldn't spin at all. i know this because the disc would come out the same way as i put it in. the only way to fix this issue is to keep taking the ground off the battery so the headunit can reset. have you've had any similiar or issues with your kenwood.???????sd
 

·
Registered
Joined
·
140 Posts
Discussion Starter #11
No I didn't do a review of the speakers. They sound ok, better than stock. 55 bucks .. that's about it.

As for the CD, I haven't even put a CD in the player yet heh. I know the Kenwood has like a Force CD mode where it'll force some incompatible discs to play. Maybe turn that off/on? I'll check it out later today and report back.
 
1 - 11 of 11 Posts
Top