Honda Element Owners Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
My honda is a 04 ex with 60k miles. About 3 years ago it started making noise from the front end creaking/clunking sounds. I switched out the shocks and struts as per mechanic advice but my oem ones were perfectly fine and he just wasnt sure what was making the noise. After that i changed the mounts. I also changed both control arms w ball joints. And then this year my right side strut started making a loud noise and then broke. Had front struts replaced again recently and the car is still making noise and different mechanic said it was the mounts again which are less than a year old... I really want to get this fixed but dont want to keep going in circles :( has anything like this happened to anyone else? Can anyone reccomend a good brand for mounts that wont break really fast?
 

·
Registered
Joined
·
221 Posts
Here's something you can try for free that helped me: unbolt the sway bar end links from the control arms. Pivot the sway bar and end links up and out of the way. Then drive around and see if the noise is gone. This will tell you if the end links are the source of the noise and not the struts. Also, inspect the sway bar rubber bushings while you're under there. Both the bushings and end links are cheap to replace.

What exactly broke on the strut?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Not exactly sure what part of the strut broke but car was completely tilted towards the broken strut. Mechanic just said the strut had broken but nit exactly what part of it but switched out both front struts for new ones. Thank you for the suggestions I will try that
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Mechanic did tell me the mount was getting cracked though. Not sure what brand I should invest in to last me more than a year
 
1 - 6 of 6 Posts
Top