Honda Element Owners Club banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I am new to this forum and owning an Element. I just bought an Element today. It is used and of course with all used vehicles, you have little problems. My problem is, the cruise doesn't work. The cruise button by your left knee will not illuminate. I have checked all of the fuses inside and under the hood (none blown). I have also checked all the connections to the switch and the servo (all good). Any suggestions?
 

·
Registered
Joined
·
3,067 Posts
I am new to this forum and owning an Element. I just bought an Element today. It is used and of course with all used vehicles, you have little problems. My problem is, the cruise doesn't work. The cruise button by your left knee will not illuminate. I have checked all of the fuses inside and under the hood (none blown). I have also checked all the connections to the switch and the servo (all good). Any suggestions?
First....WELCOME....:)

Dumb question (but only because I do this kinda thing) are you sure it's just not the bulb?

And then I'd guess the switch.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
yeah, I'm sure. I tried it on the test drive with no luck. I assumed it was a fuse at that time so I didn't worry a lot about it. Now it locks like it may be a little deeper. I will check the switch. Thanks.
 

·
Registered
Joined
·
37 Posts
Try the switch in the other position! Then check the cruise control. Seems like I had a siilar issue when I got mine. It was just the bulb burnt out
 

·
Registered
Joined
·
178 Posts
Try the switch in the other position! Then check the cruise control. Seems like I had a siilar issue when I got mine. It was just the bulb burnt out
:twisted::?

Two options to look at. You could easily jumper the cruise switch wire connector with a paper clip to ensure the switch is not bad. Second option would be look at the steering wheel cruise buttons. If the car was in a wreck and the airbag was deployed it could have simply been left disconnected by accident when the airbag was replaced. If everything else checks out it's time to grab a flashlight and play "let's see which wire the previous owner was dumb enough to cut".

Good luck bro
 

·
Registered
Joined
·
178 Posts
Point I was trying to make was if he is competent enough to check for fuses he surely would have tried pressing the toggle switch multiple times. His problem is probably still simply but I found the reply "Try the switch in the other position!" to be pretty arrogant. To me it fell along the lines of "was the car on?".

Just FYI, radioshack still carries the microlamp bulbs for all Hondas for only 80 cents a pop ($2.39 for 3). If you want to replace the bulb I would recommend this option over paying $4.50-$6 at a dealership.
 

·
EOC Rank: Crankypants
Joined
·
14,898 Posts
We only know what the OP tells us. There are many cases, some here at EOC, where the most obvious test was not done.

Still, Wipeout97's suggestion of jumpering the switch contacts is a good idea. Putting a continuity tester on the switch would also work.

To remove the switch, reach behind the panel and depress the tabs on both sides. Then you will be able to pull it out toward you.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
O.K. I have checked the light. It is out. There is power to and from the switch. There is power to the servo. The brake light switch is good (even the cruise side of it). All harnesses seem to be plugged in coming down column. I tried the switch in both locations just for fun(even though I new which position it needed to be in after checking for output power). I believe I have a bad servo. I am not sure how to check to see if signal is getting to the servo from the steering wheel controls(set, accel, coast etc...) I am not sure if it will show a signal when the vehicle is setting still (typically you have to be going a pre-determined mph before you can set the cruise). Any suggestions?
 

·
Registered
07 2wd 5-speedauto
Joined
·
1,699 Posts
Does the third brake light work? Seen this on gm's. The cruise module uses the filament as a path to ground.
Also be careful before condeming the module, there are many things that will inhibit cruise.
 

·
Registered
Joined
·
178 Posts
I'm going to pm you a link to a wiring diagram of the of the cruise control system. If it were me I would next check the brake pedal position switch and continue working your way through the schematic until you're good to go.

Good luck bro
 

·
Registered
07 2wd 5-speedauto
Joined
·
1,699 Posts
So what happened?
 

·
Registered
Joined
·
11 Posts
I've noticed that Cruise Control stopped working on my '05 E EX AT several months ago ( sure, after the warranty ran out ).
Cruise power switch is lit, but Cruise Control wouldn't engage. Checked the fuses. Replaced Stop&Cruise Switch.
What else I should check ? Could you send me the link for the wiring diagram too.
 
1 - 14 of 14 Posts
Top