Honda Element Owners Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,062 Posts
Discussion Starter #1
I guess this is where Brake related questions would go since they're near the Tires, Wheels and Suspension.

Recently my E Brake light has been coming on while driving. It's off after I disengage the brake but comes back on after a minute or so of driving.

I checked the E Brake switch and it's not shorted or anything.

I found this http://www.elementownersclub.com/forums/showthread.php?t=32473&highlight=Brake+indicator in a search. i guess I could try that, if it ever stops raining, but I'd rather replace the sensor that just disconnect it.

Has anyone else had this problem and any ideas on a fix?
 

·
Registered
Joined
·
1,499 Posts
My mom had this problem. Brought it in to the dealer and they said that her E brake was loose and that happens over time. Just take your center console out and tighten the rod and see if that helps. To do that, just look at the center console threads and when you see the rod, it's self-explanatory.
 

·
Registered
Joined
·
317 Posts
A lot of cars (Hondas included) will illuminate the parking brake light if the fluid is low reservior. It's easy enough to check just open the hood and look at the brake fluid reservoir to see how much fluid is in it. There is a line telling you where the (range) the fluid should be..the reservoir should be semi-transparent so you can tell almost right away if its low.
 

·
Registered
Joined
·
1,062 Posts
Discussion Starter #4
I tightened the brake cable and the fluid levels are fine. The weird thing is, the light doesn't come on right away. Not until I hit about 20mph. I guess I could check to see if all the tail lights are working. Thats an easy thing I didn't think of. But other than that I'm out of ideas. Oh I also tried disconnecting the brake fluid level sensor (the guy in the other thread tried that) and it still came on so I think it's something else. This sucks because I just got the vibration in the front end fixed. Bushing replacement.
 

·
Registered
Joined
·
1,062 Posts
Discussion Starter #5
Could dirty/old brake fluid cause this problem? I noticed the old fluid was really dark compared to the small amount of fluid I added.
 

·
Registered
Joined
·
1,062 Posts
Discussion Starter #7
I saw the note on the PDF about the brake light and ABS light being on at the same time. I had the ABS light come on a little while ago. I checked it and it was the wheel speed sensors (LF & RR). I replaced those but haven't had a chance to get it in to reset the light.

Then about 3 weeks ago the brake light would come on intermittently. Now it comes on everytime I start the car and start moving. I'll check the switch and see what happens. Thanks for the info :)
 
1 - 7 of 7 Posts
Top