Honda Element Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
So, I'm heading back to Honda for the 3rd time for the same issue: AC blows hot air. Before you ask, no a rock did not damage the condenser. (I have home depot gutter guard on mine !) Anyway, so a month ago, the ac stopped working, I took it in, and they told me the O ring was leaking so they drained the system, replaced the o ring and charged me back up. Just last week, the Ac dies again and I am MAD! (FYI, I just bought my 08 brand new with 68 miles on it in April.) So I take it back and sit in Honda for another 3 hours and they say the O ring is leaking again. Seriously? WTF?! I complain that they just replaced it so either they didn't replace it correctly or the condenser is bad. They conclude that where the o ring attaches to the condenser is defective.

Just curious if anyone else with an 08 has experienced this. I go back to Honda tomorrow for my new condenser after a week of no AC and today was the hottest day of of the year so far. It makes my hour long commute home FABULOUS.:x
 

·
Registered
Joined
·
54 Posts
Ac

I have not had any issues with my 08 except for the spongy brake issue.The wife complains the AC is too cold.I will keep any eye out im at 31K so i hope if there is an issue it reveals it self soon.
 

·
Registered
Joined
·
594 Posts
I have not had any issues with my 08 except for the spongy brake issue.The wife complains the AC is too cold.I will keep any eye out im at 31K so i hope if there is an issue it reveals it self soon.
Same here, but no wife.:lol:
 
1 - 3 of 3 Posts
Top