Honda Element Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello all, I searched around a while and didn't see anything, so apologies if this has already been addressed.

While driving yesterday, the radio occasionally turned off (screen went blank), and the indicator lights in the dash all went on, for about one to five seconds at a time.

Today, it happened again, and the check engine light turned on. I'll be taking it into a shop Monday, but I'm hoping to have an idea of what I'm up against.

Thanks,
Rimwalker
 

·
Registered
Joined
·
536 Posts
RimWalker,

If you have a check engine light on you need to have the code read so you can determine what the source of your electrical issue is. Advance Auto Parts and Auto Zone will be happy to put a scanner on your E and tell you what the problem is. Hope this helps.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
resolution

Well, for the sake of anyone reading who may see the same problems, in my case it was simply corrosion to the battery leads. When I hit a bump, it would momentarily cut power, which apparently pisses of modern cars with all their computers. Fortunately a simple, inexpensive fix.
 

·
Registered
Joined
·
536 Posts
Well, for the sake of anyone reading who may see the same problems, in my case it was simply corrosion to the battery leads. When I hit a bump, it would momentarily cut power, which apparently pisses of modern cars with all their computers. Fortunately a simple, inexpensive fix.
Glad to hear it was an easy fix for you.
 
1 - 4 of 4 Posts
Top