Honda Element Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey folks,

So my Element is cursed. In the 2.5 years that I've had it, the engine wires have been eaten by rats several times, I've had more nails and screws in my tires than I can remember, a tornado gave it a good beating, and my transmission randomly died a few months ago. Luckily that last nightmare was covered under warranty. When I asked the dealer mechanic why my transmission would go out so early, he said that sometimes "these things just happen..."

But today, as I was driving, my VSA light, check emissions light, and the little exclamation-point-inside-a-triangle light came on. The car seemed to be driving fine when I noticed these lights but shortly after that I experienced a few jerky shifts as I was trying to make it home.

I'm thinking that it's the transmission again though I got a brand new one just a few short months ago... Anyone else see these lights and know what's going on? Also, can I drive it to the dealer twenty miles away or do I need to have it towed?

Thanks!
 

·
Registered
Joined
·
43 Posts
I dont know about all the lights, but I can relate to the trans problem. Mine just got a full rebuild after only 34 grand or so on it. I would just drive to the dealer. worst that could happen is you get stranded on the roadside. I drove mine in, and it sounded like a rod knocking in it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the advice and commiseration. My E only had about 24,000 miles on it when the transmission died. I'm 38 weeks pregnant now so I really do not need any vehicle drama! But I'm taking it in today so I'll post what happens.
 
1 - 3 of 3 Posts
Top