Honda Element Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
HI folks , i changed my clutch on 5speed mt. and then the engine was not working properly i mean the rpm are uneven and also when i accelerate the gass pedal sometimes something stops the engine at 4rpm or goes all the way . next problem engine stops especially when i get off the hwy engine stops becouse the RPM are too low . the machanic explained becouse i got some sensor problems or the main computer needs upgrade. he can't check the computer becouse its not honda dealer.and they can only upgrade it. whithout changing.
my question is. when he change the clutched could he've broken or did something on the computer or made some changed? are these close to each other?
could it be a sensor that controls the RPM on the engine? Thanks
 

·
Moderatorium
Joined
·
6,408 Posts
Replacing the clutch is a complex procedure, and it is certainly possible that a connector or sensor could have been disconnected or otherwise bumped during the process.

>he can't check the computer because its not honda dealer.

???? - Not true. Basic engine troubleshooting codes are available through the universal diagnostic connector required on all vehicles sold in the US starting in 1996. I suggest you find somebody else to check your driveability concerns. Is the "check engine" light (yellow engine icon) on?

PS - It would help us help you if you completed your member profile. Thanks!
 

·
Registered
Joined
·
174 Posts
first thought is the clutch is not aligned properly or something was knocked off in the process of changing the clutch, other then that you need to restate your problem in a more defined logical order so I can make heads or tails of it. Please fill your profile in for the year etc.

You may want to repost this in the problems section
Chris
 
1 - 3 of 3 Posts
Top