Honda Element Owners Club banner

1 - 13 of 13 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter #1
So i've been saving some money up for my navi screen....i was originally going to buy the Pioneer Z110BT, but ended up getting the AVIC-x910BT....i just couldn't justify spending more than a few hundred dollars extra for a screen that was 1.2" bigger :| ANyways....I have a huge install project ahead of me this weekend....Got the Navi screen going in, HD radio tuner, Sirius & XM Satelite radio tuners, Ipod dirrect video cable, video bypass, back up camera, PAC steering wheel controll module, and while i'm back there i'm going to be running my RCA's and remote wire so that I don't have to pull the deck out again when I install my amp and sub in a few months.... Well, it's a huge list of stuff to do, but the end product is gonna be sooooo worth it :grin: I'll be posting some pics soon as the install progresses.
 

·
Registered
Joined
·
164 Posts
I just bought a Kenwood DNX9140. I am having a problem finding connectors that match the Honda harness. I bought a Scosche HA08B which is supposed to fit the Element. But It doesn't match. My harness has 8 lager pins in a group of four on each end of the connector (black connector). The HA08B (white connector) has the correct pattern but small pins in every position. I worry about the small pin (about 1/2 size) mating with the car harness especially since these are the pins that carry the power and ground. The pins for the steering wheel controls were also missing from the HA08B but I was able to move some unused pins to that location. After reading about all the problems interfacing to the balanced inputs on the factory amp I decided to bypass it with the Metra 70-1726. But I was going to install a new amp to drive the sub with the radio sub outputs. The darn power and ground pins are missing from this harness! getting discuraged...
 

Attachments

·
Registered
Joined
·
194 Posts
Discussion Starter #4
Ok!!! Sorry for the delay in getting some pictures up....this install turned out to be a bigger job than I imagined....Well it's finally done!!!!!!! I'm loving it + it's pretty cool having all the icons on the "source" menu lit up...it always felt a bit insufficient when I had the 700bt in my last car with no HD no xm and no sirius.... I also decided to change the climate controll leds to blue to match the stereo....I originally changed them to white, but blue is much better! As far as how much I paid for everything...i think i paid $700 for everything after my $100 mail in rebate ***perks of working in the car audio buisness :roll:**** I also used 70-1726 and it worked out perfect...all the other threads helped out quite a bit especially with getting the stock sub to work....mounting all the accessories was a bit of a pain...but other than that, no problems....next mod----->amp + subs !!!!! Can't wait !!!!!


 

·
Registered
Joined
·
194 Posts
Discussion Starter #8
ya...sorry about the blurry pics...they were taken with my crappy phone camera....o well....as for the led swap....it's not difiacult at all...it took about 30 minutes to do. If you have the climate controll out, you'll see six little white plastic bulb sockets....just turn them counter clockwise with a small set of needle nose or a set of tweezers...you have to take the stock bulbs out of the sockets and replace them with LEDs + ad a resistor to each + make your own possitive and negaive posts ( they are the metal wire things that wrap around the plastic housing of the socket and serve as contact points). Hope that helps!
 

·
Registered
Joined
·
8 Posts
Whats your take on the Pioneer navigation? I've heard the GPS function of these indash units is not up to snuff with some of the on dash stand alone units.
 

·
Registered
Joined
·
194 Posts
Discussion Starter #13
Hey thanks Wolf! I love the pioneer navi operating system, but then again, I've never had a stand alone unit...never saw the point since i have it on my cell phone also. This is my 2nd pioneer navi unit...had one in my old car....can't go wrong in my opinion.:roll:
 
1 - 13 of 13 Posts
Top