Honda Element Owners Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
So I had a problem not starting the other day, and saw that the immobilizer light was on. I came in and read here about how it can be caused by some loose connection somewhere behind the dash. I went back out, banged down on my dashboard, and she started right up.

It happened again today! Now, I know this means there is a loose connection somewhere in there, but I don't have the slightest clue where to look or what is involved. I'm concerned that any connection to "bang" back into place is pretty damn loose, and may come apart on me at the worst possible time and stay apart.

Do any of you folks know anything helpful about where I should look to solve this problem? It is the same keys, and no key fab, as this is a 2003. Any help about what to do is appreciated.
 

·
Registered
Joined
·
1,094 Posts
What exactly was the immobilizer light doing? Flashing rapidly when the key is in the run position, flashing slowly when the key is removed from the lock or something different?
 

·
Registered
MM 2005 EX, AT southwest WI
Joined
·
573 Posts
Here is a link to a post in the middle of a looong thread: http://www.elementownersclub.com/forums/showthread.php?p=939056#post939056 Appears to be an 03 cluster connector problem. Pressing the connectors upward and shimming them in that position with wood or fuses as spacers has worked for some, here is a picture from later in that thread which shows both the connectors on the back of the cluster and some 'shims': http://www.elementownersclub.com/forums/showpost.php?p=1224377&postcount=132. The final cure seems to be a cluster replacement for many.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
Thanks so much for the links and such. I haven't studied the flashing too much to say what the pattern is, only that the car won't start and it is flashing. Once, even after I had pulled the key out and walked away, I noticed that the green light stayed on and when I got back in, the cabin light and dash did some funky blinking. All classic signs of an electrical issue somewhere.

Sounds like you've given me something to work with, and I do have the full manual, so I'll dig in and see what I find and let you all know what happens.
 

·
Registered
Joined
·
1 Posts
Immobilizer

So, what was your results of your investigation??

Thanks so much for the links and such. I haven't studied the flashing too much to say what the pattern is, only that the car won't start and it is flashing. Once, even after I had pulled the key out and walked away, I noticed that the green light stayed on and when I got back in, the cabin light and dash did some funky blinking. All classic signs of an electrical issue somewhere.

Sounds like you've given me something to work with, and I do have the full manual, so I'll dig in and see what I find and let you all know what happens.
 
1 - 6 of 6 Posts
Top