Honda Element Owners Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Love our SOP. But heater blows cold air intermittently. Just doesn't work even at temperature, after 15, 20, 30 mins, 1 hour, whatever. Sometimes.

Took it dealer. Service guy says all it took was a jog to the gear that opens heat ducts or whatever. Still blows cold air intermittently. Took it back. Was told unless they can reproduce the problem, they won't fix it. Honda policy. Was told to come by next time it was blowing cold air.

We explained that this was inconvenient as we have lives and kids and jobs that require us to do more than drive around in our Element waiting for the heater not to work.

Told them today that they sold us a car with a faulty heater and we expect it to be fixed. We expect them to replace the heater or whatever. We expect a ride home too. Also called Honda Corporate Customer Service and opened a case. They're investigatiing.

Anyone else have this trouble?
Jim
 

·
Registered
Joined
·
4 Posts
Thank you! I'm having the same problem too. I think the service guy thinks I'm crazy! Anyway they replaced some kind of relay switch which did absolutely nothing for the problem. This morning was a foggy cool morning and had a very difficult time driving because window fogged up so bad. Absolutely no heat! I've got another call in to service to complain again.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Update - We called our sales guy at the same dealership, after we got a letter from him asking for referrals and promising $50 if someone we referred to him bought a car.
We reminded him we already sent him a friend who DID buy a car for him. And we told him that he could keep the $50 and just see to it that the heater got fixed.
He and the service writer guy — who really are OK — said all the right things, and we should hear today (9/26). Heater worked yesterday morning, not last night.
 
1 - 4 of 4 Posts
Top