Honda Element Owners Club banner
1 - 12 of 12 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I have an 09 Element EX and I want to install a Yaesu FT-7900 Ham Radio. The instructions state to connect the power directly to the cars battery. I cannot find any access through the firewall. Any suggestions on connecting the power source?

Thanks in advance:)
 

·
Registered
Joined
·
6,238 Posts
There have been several threads on How to. Let me see if I can find one for you.

Try this one.

Also put in a lager battery!

Dom
 

·
Registered
Joined
·
773 Posts
I have a Kenwood TK-790 installed in my Element as use these tapped straight into the rear accessory fuse slot, which is always hot.

It has been over a year since I did this, and have not had a single problem with the battery.
 

·
Registered
Joined
·
1,859 Posts
pop the little diamond shaped cover on the firewall behind the emergency brake out and pop a hole there. it is where the manual clutch pedal goes and there is clearance enough there for your wires.
 

·
Registered
Joined
·
6,238 Posts

·
Registered
Joined
·
1,294 Posts
Too funny!

I need to proof read the posts before posting. :D

Dom
And miss the opportunity to see that response? Never...great job MikeQBF! I truly did LOL.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Got through the firewall using YODA E SC suggestion. Drilling the hole at his suggested spot was the perfect place. I have power now I need to decide where to place the radio and antenna.

Thanks all for the great suggestions
 

·
Registered
Joined
·
31 Posts
Got through the firewall using YODA E SC suggestion. Drilling the hole at his suggested spot was the perfect place. I have power now I need to decide where to place the radio and antenna.

Thanks all for the great suggestions
When you figure it out, i would like to know what you came up with.
 

·
Registered
Joined
·
11 Posts
Ebox -

I just installed an Ft-7900R a few days ago. I used the wire routing suggested through the clutch pedal area. Got any pics of your install?

Greg
KF7EEE
 
1 - 12 of 12 Posts
Top