Honda Element Owners Club banner

281 - 300 of 339 Posts

·
Premium Member
Joined
·
1,057 Posts
Welcome to the forums!

You can twist a knob somewhere... that does a little bit. (it's the cluster dimmer? I just max it out.)

Otherwise, I'd highly suggest incandescent #74 replacements. I did red because I missed the inside of my Audi (and how much of a spaceship it felt like in there.) I had to pry up the bottom to pull out the blue gel on the ODO display because it was cancelling out the red (BLUE+RED=DARK GREY) in decent daylight.

People with LEDs love them, but I don't like how focused the light is near the bulbs.

This is how you would do the bulb replacement...
 

·
Registered
Joined
·
476 Posts
upgrade to LED's, i just installed a set i got on eBay and
holy cow what a huge difference they made. the stock ones
even at the brightest setting were lousy, these new LED's
are incredible, easily 5 times brighter than stock and they
were only $20. they are a direct swap, just pull out the old
ones and put these in, they twist lock just like the stock bulbs.
no messing around with trying to pull out the bulbs and wires.
comes with 9 LED's.

best and cheapest mod so far !!!




http://www.ebay.com/itm/LED-Package-Dash-Panel-Speedometer-Gauge-White-Bulb-for-2003-2006-Honda-Element/182222173140?ssPageName=STRK:MEBIDX:IT&_trksid=p2060353.m2749.l2649
 

Attachments

·
Premium Member
Joined
·
1,057 Posts
wow. They also have interior light kits for $7 (which I recommend. I paid $26 for mine piecemeal.) It makes the inside of your car shine like a spaceship.

I did use a red LED for the drivers side map light for some high vis light while driving, but I don't recall that one bulb being a $20 purchase.
 

·
Premium Member
Joined
·
1,057 Posts
which interior lights did you get ? my front and rear dome
lights are almost useless !
I went to Super Bright LEDs and bought bayonets bulbs in bright white. The ends were weird and I had to bend the contacts together a bit. I picked up 44mm.

I was just saying that the eBay seller with dash LEDs also has an interior light kit. Looks like SMDs. Should do the trick.
 

·
Registered
Joined
·
47 Posts
ParishM, thanks for posting the link for the instrument panel leds. I already had blue bulbs but was unhappy that they were a bit dim. Got the ones from the link and bingo, Just what I wanted. Very simple to install.
 

·
Registered
Joined
·
99 Posts
upgrade to LED's, i just installed a set i got on eBay and
holy cow what a huge difference they made. the stock ones
even at the brightest setting were lousy, these new LED's
are incredible, easily 5 times brighter than stock and they
were only $20. they are a direct swap, just pull out the old
ones and put these in, they twist lock just like the stock bulbs.

I just did this upgrade in less than 20 minutes! One of the stock bulbs was burned out and another one would come on when I banged the dash. Could not believe how easy it was to make the exchange!
 

·
Registered
Joined
·
11 Posts
ParishM, thanks for posting the link for the instrument panel leds. I already had blue bulbs but was unhappy that they were a bit dim. Got the ones from the link and bingo, Just what I wanted. Very simple to install.
Cannot find link to instrument lights

Sent from my Moto E (4) Plus using Tapatalk
 

·
Premium Member
Joined
·
27 Posts
My 2011 replacement of LED's are working just fine and no problems.
Since photo bucket changed on how to share photos like 399.00 worth I now have to update all photos if I can get to all of them and upload to this site.
 

Attachments

·
Premium Member
Joined
·
27 Posts
My diagram is for a 2011 as you can see I have given all points on the cluster to be changed if you noticed in my earlier post that the MPR and RPM have 3 leds next to the needles those are the ones to change what ever color you want for the needles now for the gas and temp they only have 2 LEDs so they are the only ones to change for different color needles the rest are for the dash color see post http://www.elementownersclub.com/forums/showthread.php?t=12718&page=2
Here is the picture that was deleted by photo bucket because I would not pay 399.00 :zombie006::zombie007:a year for 3rd party hosting.
 

Attachments

·
Premium Member
Joined
·
27 Posts
I see you have changed the face colors of your radio looks nice. Did you paint the lights or install LEDs. I want to switch to all blue dials and in the display window can I change the LCD white display to blue?[/COLOR]UPDATED = I did some digging and found your thread and found the info I needed, Thank you
Here is the pictures that photo bucket blocked.
 

Attachments

·
Registered
Joined
·
8 Posts
LED Cluster help!

HI, I have been reading here for a few months now and decided to change out the cluster, and whatever ones I could get to, to LEDs bc my 03 E seemed to be very dark even with the overheads on.
I ended up buying four different kinds of LEDs that all kinda worked somewhat but not really, I finally bought a pack with new twist locks and got them all the work, BUT they are so dim you can hardly even tell they are on???
I was testing them in the house with a 9v battery, and they were super bright, inserted the two green clips in the back turned the lights on and ........like 1 out of 10 for brightness.
What the crap am I doing wrong, the 9v battery lit up the whole cluster very well but installed in the car it might as well not even be on.
If anyone has had this problem ID love to hear from you.
Thanks!
Chris
 

·
Registered
Joined
·
8 Posts
Help with LED in cluster E04?

HI, I have been reading here for a few months now and decided to change out the cluster, and whatever ones I could get to, to LEDs bc my 03 E seemed to be very dark even with the overheads on.
I ended up buying four different kinds of LEDs that all kinda worked somewhat but not really, I finally bought a pack with new twist locks and got them all the work, BUT they are so dim you can hardly even tell they are on???
I was testing them in the house with a 9v battery, and they were super bright, inserted the two green clips in the back turned the lights on and ........like 1 out of 10 for brightness.
What the crap am I doing wrong, the 9v battery lit up the whole cluster very well but installed in the car it might as well not even be on.
If anyone has had this problem I'd love to hear from you.
Thanks!
Chris
 
281 - 300 of 339 Posts
Top