Honda Element Owners Club banner
1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
i'm trying to locate the IAT for my 04 element. any 1 know the exact location? or maybe pics? any and all input would be most appreciated.

ps. i have the slr motorsports performance chip and i need to locate the IAT in order to install it. i don't have the repair manual yet.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 · (Edited)


is this the IAT? thanks for responding!!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Thats the one.
thanks again!! this site rox!! i've owned my element since new, it now has just over 100k(never one problem) and i just found this site this morning. looking forward to learning and sharing as much info as i can here.
 

·
Registered
Joined
·
6,238 Posts
Some other people have posted on the results you will get with that chip.

Look at this before you install it!


Dom
 

·
Registered
Joined
·
72 Posts
1st, welcome to the site!
Please don't do this mod. This type of mod is a simple bypass that worked in older cars because they did not have all the computer controls of today. It was a simple enrichment mod that worked based on Throttle body position & air intake temp.

But today's cars also incorporate fuel pump pressures, coolant temps, etc.

Ever notice your E doesn't always have an "instant" start up? It's because the E has an adaptive onboard CPU to optimize and reduce emissions.

Splicing into this harness is simply going to cause issues down the road, even if you remove the mod. Save yourself the headaches.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
i did install the slr chip. i did a lot of research b4 coming to this site and decided it was something i wanted to try. i also have the hydrogen kit from alternative propulsion engineering. the last road trip i made from here to the mountains of north carolina we averaged between 24 and 27.7mpg(hwy). so i'm hoping the slr chip will improve on that. but again thanks for all input and info.
 

·
Registered
Joined
·
874 Posts
I tryed one of those chips on my montaro mpg went down almost 4 mpg. it was cheep and I wanted to know just how much it worked if any.I didn't splice any thing I made a pigtail. & you will never hear from the seller again. it did almost exzackly what I thought it would do. the montarow v6 was gutless & got 15 mpg to start before I added the "chip" & went down from there. & I tested it on highway millege to get a beter base line.across a flat state.
 

·
Registered
Joined
·
751 Posts
i also have the hydrogen kit from alternative propulsion engineering. the last road trip i made from here to the mountains of north carolina we averaged between 24 and 27.7mpg(hwy). so i'm hoping the slr chip will improve on that. but again thanks for all input and info.
Did you have the hydrogen kit when you got that fabulous 24-27.7 mpg? B/c I don't have any said hydrogen kit and got similar mileage. :lol:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #12 ·
Did you have the hydrogen kit when you got that fabulous 24-27.7 mpg? B/c I don't have any said hydrogen kit and got similar mileage. :lol:
yes. i also noted u have the 2wd. mine is the 4wd exs, i had myself and spouse, rear seats pulled up and tons of luggage and xmas stuff in the back when i calculated the mileage. also note a good deal of the driving was in the mountains.
 

·
Registered
Joined
·
874 Posts
my E gets the best millage in the mountains, much to my surprize.but when I thought about it it made sense, cost for miles using very little & cant go real fast through the winding roads so it's not using much if any more than city driving.
 
1 - 13 of 13 Posts
Top