Honda Element Owners Club banner

1 - 4 of 4 Posts

·
Registered
2010 Honda Element EX alabaster
Joined
·
77 Posts
Discussion Starter #1
2010 Honda Element EX 93,000 miles

So I thought my tranny was going out the other day due to slipping/missing gears while driving all a sudden. I had been having idle issues too lately, but nothing major. Changed my plugs and still had minor idle probs, just thought I needed valve adjustment.

I have lifetime tranny warranty b/c I bought new from dealer. so anyway, I bring to Spring Branch Honda yesterday in Houston and they run all the diagnostics and drive it and get it to repeat the malfunction. They then tell me it's not the tranny, it's the engine oil switch. They keep overnight for part, change the oil switch for $325 and just called me back. They said they fixed the switch, but the engine light came back on or the same error code came up (cant recall exactly) and it's because my aftermarket oil filter is too small. So I ask, so I don't need my oil switched replaced? and he said oh yeah you did, but you need Honda oil filter too. He said the aftermarket oil filter is too small. I never had a problem or lights coming on since last oil change or oil filter change. What do you guys think? Should I pay for the new oil switch they said they "had" to replace, or I fight it and all I needed to fix the issue was an oil change with a Honda oil filter?

If you know anything about this please respond asap because I am about to go pick it up and hence have to pay $325 plus $50 round trip uber/lyft to dealer. Thanks!
 

·
Registered
2010 Honda Element EX alabaster
Joined
·
77 Posts
Discussion Starter #2
Got two miles down the interstate and same thing happens. Skipping/slipping gears. Back at dealer. Says I need the oil filter and change. Then it will all work perfectly. If they put my life at risk and send me down the road again and it recurs, I’m gonna go ballistic on these guys.
 

·
Registered
2010 Honda Element EX alabaster
Joined
·
77 Posts
Discussion Starter #3
Those sons of bitches sent me on my way again with an oil change and new Honda oil filter. All assurances it would be safe and operate properly. Didn’t get one mile and it’s red lining rpms before 55 mph. Not switching gears at all. Turned around and brought it back. They were trying to close. I was extremely pissed. Left over night again and they called me an Uber. I’ve spent $400+ and tomorrow will be my third day without a car. Anyone have any ideas?
 

·
Registered
2010 Honda Element EX alabaster
Joined
·
77 Posts
Discussion Starter #4
I'm pretty sure all they needed to do was clean my solenoid gasket screen. or replace it. Those are $4 at oreillys. Today is my 3rd day with no car and they still haven't reached out to me since yesterday's fiasco. Ridiculous. I've bought my only 2 cars in my adult life there... a used 03 Element and a new 2010. You'd expect better from a dealer.
 
1 - 4 of 4 Posts
Top