Honda Element Owners Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1 (Edited)
Just asking what your thoughts are on the below info

I already have the HU , main amp, sub amp and speakers.

HU - Clarion nx 409 http://www.clarion.com/us/en/products/2009/multimedia/navigation/NX409/us-en-product-pf_1172409026738.html
main amp 16-MC4.50 by Memphis http://www.memphiscaraudio.com/products/amplifiers/class-ab-mclass-amplifiers/
sub amp - 16-MCD250 by Memphishttp://www.sonicelectronix.com/item_12337_Memphis+16-MCD250.html
Speakers - POLK AUDIO DB651S 6.5" x 4

thinking about JL AUDIO 6W3V3-4 6.5" SUBWOOFER 4ohm volume required is .15 cf http://mobile.jlaudio.com/pdfs/13977.pdf

I do not want to modify or have a bigger sub, i am trying to keep it looking like a stock setup other then the HU

Cheers
 

·
Registered
Joined
·
24 Posts
Just asking what your thoughts are on the below info

I already have the HU , main amp, sub amp and speakers.

HU - Clarion nx 409 http://www.clarion.com/us/en/products/2009/multimedia/navigation/NX409/us-en-product-pf_1172409026738.html
main amp 16-MC4.50 by Memphis http://www.memphiscaraudio.com/products/amplifiers/class-ab-mclass-amplifiers/
sub amp - 16-MCD250 by Memphishttp://www.sonicelectronix.com/item_12337_Memphis+16-MCD250.html
Speakers - POLK AUDIO DB651S 6.5" x 4

thinking about JL AUDIO 6W3V3-4 6.5" SUBWOOFER 4ohm volume required is .15 cf http://mobile.jlaudio.com/pdfs/13977.pdf

I do not want to modify or have a bigger sub, i am trying to keep it looking like a stock setup other then the HU

Cheers
I'm looking at the same receiver. I'm getting mixed feedback. Some really like it, some say it's 'laggy'. I'm only to guess that it means that it's sluggish when using the touchscreen. Over at crutchfield, it seems like it's the only one to get consistent good reviews out of the sub $1000 DD nav units.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
I like it

Can any one out there give me a review on the components or sub im going to use does itlook like they are all compatible ?
 

·
Registered
Joined
·
562 Posts
I love the jl 6w3v3. I have had it for about 1.5 years being pushed by a jl 250/1 under the passangers seat. everything went in easy and it sounds good. its not a 10" or anything but for not taking up any room its got some bass.

wish I could say the same about the alpine pdx...but soon to be fixed with a jl audio xd400/4 that is heading my way in the mail.

I also have the db 6.5 speakers and they sound good (except for a audible hiss/squeal) but thats the pdx.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #6 (Edited)
Awesome.....thanks for the picture that really clears it up ....awesome


i take it you closed off the port and did you stuff it with anything?
 

·
Registered
Joined
·
562 Posts
I had considered that until I found a lot of car audio posts saying the sub performs better with some air to move it so I left it open. Its not real tight but I think it might get more range with the port which I decided to try. Not going to get a real tight hit with a 6" sub no matter what you do. It just can't move enough volume. So I aimed for sound quality and range.
 

·
Registered
Joined
·
1,266 Posts
Actually a 6" sub SHOULD hit tight. What you lose with a small diameter woofer is low frequency extension. If it's sloppy, then you've got to close that port.
 
1 - 8 of 8 Posts
Top