Honda Element Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1 (Edited)
I have a problem with my Driver's door. When I open the door, the car doesn't recognize the door is open... no light and the car will re-lock cuz it doesn't register that the door is open...

I bought a new switch thingy, (the little button that is on the back door.) But it still doesn't work.

Any ideas what to do next?

Thanks in advance,

Tam
 

·
Registered
Joined
·
161 Posts
Discussion Starter #3
You might have a bad ground on the door switch. The screw that holds the switch in the door is also its ground; check for corrosion. Also check under-dash fuse #10 and under-hood fuses #3 and #9.

Does the passenger's door switch work correctly?

Thanks Dan, I will check those fuses when I get home next weekend (in NC and SC for work this week)

Yes the passenger's door works. I checked the ground, it looks good. The light turns on when I open the back door on the Driver's side, just not the Driver's door. Lights also come on when I unlock the doors with the keyless entry.

Do ya think the driver's door would have it's own fuse?

Tam
 

·
Registered
Joined
·
2,689 Posts
all the doors share the same fuse.
(power comes from battery thru fuse and wiring to light.)
each of the doors can provide a ground to complete the circuit.
so, if the driver's door doesn't have a ground it won't complete the circuit.
if you've already changed out the switch, then it has to be a problem w/ either the wiring that goes to the door switch, or the ground on the switch.
 
1 - 4 of 4 Posts
Top