Honda Element Owners Club banner
1 - 11 of 11 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter · #1 ·
ok so
it seems that i shorted out the PRND21 light...
only the pointers on the cluster light up (not the numbers) and the heat/ac selector does not light up, nor the hazards button.

what fuse is this? i checked them all.. what can it be?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #2 ·
all of the fuses are fine, i have no idea where to even start to look now...
can anyone help please?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #3 ·
alright, it may be a cluster....
is there anyway to test the cluster to see if that is it?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #4 ·
wiring diagram??

does anyone have a wiring diagram for a 04 element ex cluster?
there are two harness' that clip in the back of the cluster gauge..
can someone lead me to what they are for...

thanks alot
Dom
 

·
Registered
Joined
·
1 Posts
My instrument cluster light doesnt work

I have the same problem.....my instrument cluster light the prnd doesnt light up neither ...i check the small light fuse its ok..i even replace it to a good fuse please tell me what can be the problem or where else to check
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #6 ·
Odometer.

if i were to buy a cluster is honda or someone able to reprogram the odometer to what is listed on my odometer?
 

·
Registered
Joined
·
1,911 Posts
I know it can be done on other cars but not sure on the E. Whats wrong with yours?
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #8 ·
cluster is fried;

took it to the dealer they diagnosed it the 1st time as "need to replace all bulbs" they wanted a total of $380.24 for install and 12 bulbs.. i was like :shock: so i said leave it and took it home, put a ohm reader on the bulbs and they were all fine.. so i took it back this morning and after 1.5hr labor($250) they said its the cluster that is gone. so i am looking at autowreckers and can get a cluster for about 200 instead of 900..
so i just want to see if it can be done.
 

·
Registered
Joined
·
300 Posts
Discussion Starter · #9 ·
ok here is the diagnostic.
" continued to trace pwr. all the way to gauge assembly. found internal falt in gauge assembly causing issue. verified by bypassing ground through gauge assembly and all lights worked"
now is there any way to bypass the ground wire to make this work??????
 

·
Registered
Joined
·
300 Posts
Readings stored?

Does anyone know if the ECU stores odometer readings?
or if anything else stores readings?




MODS NOTE: These threads have been merged because you keep starting a new thread for the same problem or question. Multiple threads in not going to get your question answered any quicker.
 
1 - 11 of 11 Posts
Top