Honda Element Owners Club banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Problem with shutdown, very low RPM.

Due to the theft of the catalyst, a catalyst and its sensors were bought after they were installed, there are still problems, because at the moment of starting the car and after 10 minutes it starts with the trip and at the moment of turning or turning the steering wheel without Accelerating the car turns off, you have to put the car in park, turn it on again, in due course sometimes it turns off again if you turn the steering wheel, so you have to put in Drive and accelerate before turning.
After this, the car has been on for a while and having driven a long distance, the car no longer turns off unless the car is left off for hours and the same situation happens again.

It currently has the P1157 code and the P0506 code.

Has someone something similar happened to him?
 

·
Registered
2004 EX AWD
Joined
·
42 Posts
It sounds like your idle air controller may be bad (which is the P0506 code). I IAC valve fine tunes the air/fuel mixture at idle. A dirty IAC valve, or the orifice it controls being dirty, can also result in stalling. Looks like aftermarket IAC valves are fairly cheap. I'm not sure if this could cause the P1157 code. I suppose it could since it affects the air/fuel ration, but I didn't see anything on google showing it commonly coincides with it. The P1157 code refers to your upstream (before the catalytic converter) O2 sensor. It could be failing, especially if it was replaced with a cheap aftermarket one. Could also be an issue with the wiring. If the thief tore out the O2 sensor and the shop spliced in the new one, I would look there for a faulty connection. The upstream O2 sensor also affects the air/fuel mixture.
 
1 - 2 of 2 Posts
Top