Honda Element Owners Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
We have a 2007 Element base LX model. (no carpet)

Just wondered if anyone has any tricks for opening the side panels (interior rear panels) where the hitch wiring is supposed to be connected. Have noticed that some of these panels can be alittle tricky especially where Honda's fancy clips are used. Apparently, your supposed to remove the rear
passenger side panel where the foldown hook is. Again, supposedly the connection for the wiring is behind this panel.

Any info would be appreciated
 

·
Retired.
Joined
·
12,183 Posts
We have a 2007 Element base LX model. (no carpet)

Just wondered if anyone has any tricks for opening the side panels (interior rear panels) where the hitch wiring is supposed to be connected. Have noticed that some of these panels can be alittle tricky especially where Honda's fancy clips are used. Apparently, your supposed to remove the rear
passenger side panel where the foldown hook is. Again, supposedly the connection for the wiring is behind this panel.

Any info would be appreciated
Are you using a Honda harness or an aftermarket harness?

If you are using a kit the instructs you to install the harness behind the passenger side panel you have the wrong kit.

For the 2007's all the connections are made under the dash and in the spare tire well.

If you have a Drawtite 118336 kit it will not work for you.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Hello lizzurd

The kit that we puchased was from Canadian Tire- a generic brand that they say can be used on the Honda Elements including SC models from 2003 upwards, as well as other auto vehicle types. Inside the packaging are instructions for several auto types including the 07 Element, but as usual they're sometimes difficult to read. I could be wrong but am almost positive it says to remove the rear side panels. I do know that it clearly says to remove the tailgate flapper.

Would apppreciate any advice
 

·
Registered
Joined
·
162 Posts
Are you using a Honda harness or an aftermarket harness?

If you are using a kit the instructs you to install the harness behind the passenger side panel you have the wrong kit.

For the 2007's all the connections are made under the dash and in the spare tire well.

If you have a Drawtite 118336 kit it will not work for you.

good thing I am just getting a hitch installed this weekend but not wired. I would have to try and move the 100 lb stereo sitting over the spare tire well.
 

·
Registered
Joined
·
662 Posts
But the directions for removing it are here in H and A's instructions for installing a rear power port.

I just found and printed out the diagram for removing the rear panels you offered here. Thanks ;-) It is described better than in the service manual.

It's been 5 years since I had one of the panels off to wire the hitch and I just plain don't remember how I did it-----it happens often :D

I'm on a tire noise quieting mission as the Michelin Pilots were reasonably quiet until they got to be 1/3 worn. Now, it's starting to sound like the old Wranglers.

I removed both front wheel well liners and installed soundproofing material. Now, I can only hear the road noise from the rear instead of all over.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top