Honda Element Owners Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I purchased my 2003 Element in Oct. 2006. I have had no real issues until a few months ago when I moved to Jersey City from Florida this summer. In July, the battery died, so I went to Pep Boys- they confirmed it was bad and sold me a new one. All was well until September, I noticed it was hesitating when it started. Finally, one morning- it wouldn't start at all. I got a jump start from a neighbor, but later that day- it wouldn't start again. I kept trying and eventually got it down the street to a mechanic. They ran a diagnostic- the starter and alternator were fine. They gave the battery a full charge and kept it for a couple days, starting it a few times each day with no problems- so they had me come pick it up. They said since I don't really drive it except to move it for the street sweeper everyday that I should try driving it a little everyday. So I drive it a couple of miles daily now except on the weekends. I had no further problems until a few days ago, the hesitation started again and today it was dead. Pep Boys tested the battery again and said it was fine. One of the mechanics from the shop I took it to was nice enough to drive down and take a look at it. He said the starter moves when I turn the key, and I have power to run the lights and everything- so he's not sure what the deal is. Before I spend a ton of money- has anyone else had this problem? And if so, what was the end result.
Oh yeah, and the keys don't work in the driver's side door- won't turn at all. I tried WD40, but it didn't help. Any ideas?
 
1 - 3 of 3 Posts
Top