Honda Element Owners Club banner

1 - 5 of 5 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter #1
For awhile my E has been running a bit rough. You'll be driving, doesn't matter what speed, and there's a strange hiccup/hesitation. Almost like a very brief loss of power. Just changed the oil/filter and air filter. Then even stranger I'm driving and it half stalls. Its still running but the oil and battery light come on and it gets harder to steer but still running. When stopped it feels like its going to stall but the RPM's remain steady at just under 1k, no wavering. So what is it? Needs new spark plugs? New battery? I read that you can take certain solenoids out and clean them. Please tell me its not something costly like the fuel injection or the alternator :(
 

·
Registered
Joined
·
174 Posts
Well you can only answer if needs spark plugs as thats pretty much based on the miles, after that it could be a number of things.

An engine that dies at lights tends to be starved for air, or fuel, so the obvious things would be fuel filter, injection cleaning, and throttle body cleaning. It might also be the idle speed control(IAC), loss of vacuum, or a number of other things like a bad fuel pump or battery also.

Oil and battery light are coming on because your RPM's are low, at least thats my guess.

Chris
 

·
Registered
Joined
·
319 Posts
Discussion Starter #3
Right now I'm creeping up on 75000 miles. After reading that the battery should be replaced at 4-5 years I might try that.

Its not dying at lights just running rough. The oil/battery lights are coming on while driving and there is a loss of power steering, not all the way but partial loss while driving.
 
1 - 5 of 5 Posts
Top