Honda Element Owners Club banner

1 - 17 of 17 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
What is the strongest battery that you can buy off the shelf for the Element? I've got the original 410 CC, and it'll need replacing soon. I've looked at the older battery threads, but was wondering if anybody made a recent purchase.
 

·
Registered
Joined
·
1,911 Posts
I just also installed a 56 and it has more cranking amps and is working great.
 

·
Registered
Joined
·
90 Posts
I also had an Autozone Duralast battery in my late Element and had no issues with that battery... You also have to consider that I did have an upgraded stereo in my E and that battery (Duralast) handled it just fine.
 

·
Registered
Joined
·
1,062 Posts

·
Registered
Joined
·
16 Posts
Can someone show their pics of the 56 battery install? I've been to my local AutoZone and Walmart. Neither has a 56 size. Would a Interstate MegaTron MT-56 be just as good or has anyone used this one in particular?
:twisted:
 

·
Registered
Joined
·
10,181 Posts

·
Registered
Joined
·
16 Posts
+

Just follow the link in post #2 of this thread.
Lizzurd, when I open this thread it says the pictures are no longer available or deleted and there's a picture of someone's baby and some construction work posted along with the text about the battery.

Can you guys see the pics on this thread he's talking about or am I stuck in the "thread twilight zone"? :shock:
 

·
..
Joined
·
12,180 Posts
Lizzurd, when I open this thread it says the pictures are no longer available or deleted and there's a picture of someone's baby and some construction work posted along with the text about the battery.

Can you guys see the pics on this thread he's talking about or am I stuck in the "thread twilight zone"? :shock:

Posts #72 & 73 in the link posted below show the group 56 install.

http://www.elementownersclub.com/forums/showthread.php?t=50371.
 

·
Registered
Joined
·
10,181 Posts

·
Registered
Joined
·
229 Posts
Quote:
Originally Posted by zgelement View Post
Can you guys see the pics on this thread he's talking about or am I stuck in the "thread twilight zone"?

NO
 

Attachments

·
Registered
Joined
·
10,181 Posts

·
Registered
Joined
·
229 Posts
Are you sure you're looking at posts #71 and #72 in that thread? It'll be a few pages in. Pics show up fine for me for the record.

Your right. The image I posted was post "one" of that thread. Post #71 and #72 show the pictures just fine. Maybe that was zgelement mistake also.
 

·
Registered
Joined
·
1,486 Posts
Interesting. The pictures are not showing up for me either.
 
1 - 17 of 17 Posts
Top