Honda Element Owners Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Yup, I'm the guy looking for the used OEM Subwoofer in a slightly earlier post but someone mentioned to me that it could be the Amp that is bad? All I know is that with the subwoofer turned to the minimum setting (essentially off) the rest of the system sounds normal, even when turned up a bit. If I dial in the subwoofer, especially setting it to the maximum "plus 5" setting and then play something with bass, it just blatts and rattles but the other speakers all sound fine. Any advice as to whether it is indeed probably the subwoofer itself or the amp? Sorry for a second post about basically the same topic buit I'd hate to buy a sub only to find out it is the amp. Thanks!!
 

·
Registered
Joined
·
198 Posts
In my experience if something was wrong with the amp it wouldnt be working at all. If the sub is rattling and popping it sounds like its blown.
 

·
Registered
Joined
·
557 Posts
IT sounds like blown to me. The amp will not make it make popping and gurgling noises, that comes from the rubber or foam surround tearing or the coil unwinding, both require it to just be replaced, unless you have a kit to repair that particular subwoofer.
 

·
Registered
Joined
·
8,046 Posts
I just replaced my stock sub. If you want it, send me a check for $30 and I'll ship it out to you. Seriously. PM me if interested.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Yup, Had the enclosure cover off.

I did remove the enclousre cover so I could see the subwoofer and baffle assembly and the subwoofer looks fine, no obvious tears in the cone or surround or anything like that. It just sounds awful and rattley when you actually dial it in. Sounds blown to me so I'm going to take a gamble and replace it first. The old process of elmination starting with the obvious. Thanks for all the replies and help!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Installing OEM subwoofer easy or hard?

Is it pretty easy to install a new OEM subwoofer if you have the OEM unit pre mounted to the baffle and pre wired? Does the whole thing just bolt in place? Do you have to use sealant or caulk or anything? Thanks!
 

·
Registered
Joined
·
2,178 Posts
Is it pretty easy to install a new OEM subwoofer if you have the OEM unit pre mounted to the baffle and pre wired? Does the whole thing just bolt in place? Do you have to use sealant or caulk or anything? Thanks!
IIRC it just has a plug in the back and 6 screws holding it in the box

 

·
Registered
Joined
·
8,046 Posts
Don't bother pulling out the entire enclosure. No need for it.

Just take out the screws around the sub, disconnect the 4 spade terminals on the driver, do everything in reverse with the new one.
 
1 - 10 of 10 Posts
Top