Honda Element Owners Club banner
1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I just got my E last week and its a MT. My stick driving was a little rusty so i dont think i picked up on this on the test drive. Im having problems with the pas pedal being stubborn. It doesnt want to move when i first put my foot on it until ive put excessive pressure on it. Then it finally budges but the pressure from my foot makes the tach jump up to about 3k. Basically its just sticking in the closed position and its making things a little bit of a nag.

i looked under the dash and all the gas pedal mechanisms are heavily lubed (didnt get a chance to look at the actual throttle cable).

its still under warrantee from the dealership and i was thinking about taking it in and asking for a throttle body cleaning. Does this sound accurate?
This is something i would usually do myself but i figure they need to earn their keep for the next 2000 miles..

thanks,
daniel
 

·
Registered
Joined
·
1,500 Posts
dan, there are quite a few threads about issues & adjusting the throttle cable, if thats the problem.....either way if your under warranty make the dealer remove it, clean it, adjust it & re-install.... good luck...Pat
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
dan, there are quite a few threads about issues & adjusting the throttle cable, if thats the problem.....either way if your under warranty make the dealer remove it, clean it, adjust it & re-install.... good luck...Pat
yea i read those posts about the cable itself. but it doesnt seem like theres any extra play in mine

i guess my question is:
should i be able to feel my TB sticking closed just from my gas pedal?

-d
 

·
Registered
Joined
·
1,235 Posts
yea what he said. mine was doing the same. if i haven't touch the pedal for a while it would stick. found out it was sticking on the engine side. I clean the throttle plate twice for it to completely go back to normal. clean the part where the plate connects to the TB good.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
yep, it was a dirty tb butterfly valve issue. took it in today and watched the mech clean it really well. thanks all

just a heads up: NEVER pay for someone to clean your throttle body. not more than a five minute job...

thanks for the help eoc
 
1 - 6 of 6 Posts
Top