Honda Element Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
Hello all!
It's been a while since I've been on here, but I've still got my E and it's running strong!

My question today is about the Accessory Trailer Hitch Wire Harness Recall. I took my E to a dealer and had them do the recall, but they said they couldn't properly do it because there was no power being supplied to my hitch wires. They also said that the Control Unit was missing...but after my own inspection, it appears it might already be there...so I'm not sure if I have a problem or not.

Recall notice and service manual:
https://www.handa-accessories.com/element/harnessrecall.pdf

Photos of my E's wiring for the trailer connection area under the steering wheel (to the left of the fuse box)
1)
https://www.cubbyusercontent.com/pli/IMG_2815-private.JPG/_ae2e9fa2ac2f4111842b11e4325b2e57
2)
https://www.cubbyusercontent.com/pli/IMG_2816-private.JPG/_82513cb99c7f42f8b5f529e8f7705280
3)
https://www.cubbyusercontent.com/pli/IMG_2817-private.JPG/_3be33a2365c543dea25c27ac1736e2b2
4)
https://www.cubbyusercontent.com/pli/IMG_2818-private.JPG/_f64f11687b054b51bf043ba42e4946f2
5)
https://www.cubbyusercontent.com/pli/IMG_2819-private.JPG/_0764cb8a160e4884abccd99da2b46c1c
6)
https://www.cubbyusercontent.com/pli/IMG_2820-private.JPG/_7badee51a0534f3d8b2c12e7d574af4e

Am I missing a control unit? If so how can I acquire it and fix the problem? Just want to make sure I've got everything properly working, and I can't tell if the dealer didn't know what they were doing, they are trying to nickel and dime me, or if this is actually a problem.

Thanks in advance!
 

·
Retired.
Joined
·
12,182 Posts
That's the keyless entry module. It would appear you never had the trailer light module installed.

The connector for the trailer harness module is grey and keyless module is green.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
That's the keyless entry module. It would appear you never had the trailer light module installed.

The connector for the trailer harness module is grey and keyless module is green.
Ah! Ok that makes sense. Any idea what that part number is? And can I just install it myself real quick?

Thanks!
 
1 - 4 of 4 Posts
Top