Honda Element Owners Club banner

1 - 10 of 10 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
I have had this HID Kit for a few months now. Its a Xentec HID Kit and is the same size and that a honda factory bulb is. There High and Low beans and the guy that i bought them from said that this plug....



goes into the Honda High Low control unit. Does anyone know where this plug will plug into? Really looking to get these on the E. There Purple so it should look great to contrast the Omni Blue Pearl paint.
 

·
Registered
Joined
·
228 Posts
I believe that plugs into the factory harness
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3 (Edited)
now the question is where in the harness would i find its female? A helpful internet pointing of the finger would be AMAZING!!! LOL

Really means alot! We got lots a LOTS of animals wild in North GA so we need to see just a bit better. Thanks robc!

If not I might take that photo to honda down the road and see if they known. But i really hate going in there to ask them
 

·
Registered
Joined
·
228 Posts
Mine didn't come with that plug for my HID's, but I've installed some on other cars that have that plug. It connects to factory harness where it plugs into bulb.
 

·
Premium Member
Joined
·
958 Posts
Probably the wrong kit for your vehicle. That plug is supposed to be connected to one of the plugs that connect to the halogen bulb.
 

·
Registered
Joined
·
1,447 Posts
agrees. you got a single bulb kit with high/low?

that was prob a setup for older element

now ide have to go look at mine in the morning but. dont we need 2 bulbs? one dor DRL/high beam and one for low beam?

And I would not suggest HID in our DRL/high beam as yes it uses a standard bulb. but in DRL mode its running at like sub 50% voltage and I wouldnt trust it with HIDs and besides. 3000-5000 hr life would be used up pretty fast with the DRL

Edit:
I just looked up the parts. all elements use an HB2 bulb.....but its the main bulb in older elements. its the DRL/high beam in 09-11 and low beam is an hb3

judging by that socket it looks to be a 9007/HB5

a hb3 should look like this (low beam)


a HB2 should look like this (high beam)
 

·
Registered
Joined
·
109 Posts
Discussion Starter #7
Well the SC has DRL's and High/Low beams so yes we do have 2. All the bulbs plug into the ballasts right. Its just that one big blue plug i cant figure it out. The guy i got them from helped me with the research to. I just think that the harness is wrong maybe not sure. I think i might take them to Sound Sensations and see if they can put them in and if not i will by a kit off of them but they have to be PURPLE ^_^ seen a OBP with purps on it looked really nice.
 

·
Registered
Joined
·
715 Posts
I have an '09 and mine does not have the big blue plug. Your hi/low is controlled by the plug that went onto the end of the original headlight bulb. You can do a you tube search for hid installations and see a lot of them being installed. Yours with the single hi/low bulb would be the bi-xenon kit.
 

·
Premium Member
Joined
·
958 Posts
you can try to get a female plug from a junked element and rewire it onto the hid kit. was this kit used?
personally, i would just get another kit and use the one you have for extra parts in case something broke on the new kit.
 

·
Registered
Joined
·
2 Posts
2007 SC HID Xenon Install help needed

Hi all,

Got my Philips H11 HID kit and ran into problems..after installation.. everything
connected, no light.. The kit came w/ a relay harness... Do I need to use that
to get it to work on my 2007 SC.

Thanks a bunch.
Steve
 
1 - 10 of 10 Posts
Top