Honda Element Owners Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2007 Honda Element 5DR EX (4WD) | KA 5AT

I have had an issue with the VSA and Engine light coming on and making it hard for me to accelerate. This week or next I will be dropping it off at the mechanic so we can figure this out.
This problem also happened last year, not as consistently as it has been for the past couple of weeks. It may seem weird (since I have read others report the same complaint during cold weather) but for me this happens only when it is HOT outside.
Last year (on hot days) the VSA and Engine light would turn on, I did take it to a mechanic but on that day it was getting cold and the lights did not turn on...classic. lol. During this past winter i have had no problems with my car, but as the days are getting warmer here in Houston, the lights keep coming back on more frequently.

I am aware that all problems are different but, and I wont know anything till i have the codes read but was wondering what kind of solutions did others found to similar problems.

Thanks
Javy
 

·
Registered
Joined
·
3,060 Posts
There's an OFF switch for the VSA on the dash by your left kneecap. See if that helps until you get it in to the shop. Sounds like maybe you have bigger problems though.
 

·
Registered
Joined
·
1,112 Posts
I had that problem when I needed to accelerate hard to get into traffic. Heart in throat when traffic is bearing down on you and the dam engine cuts out. Disconnecting the battery for 20 minutes reset the computer and fixed mine. Get the radio code first. (glove box or manual) And you will need to reset the driver window. (hold it down after a few seconds after its all the way down and the same when it goes up) I hope yours is as easy to fix. And welcome to the forum.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I got the code read P2138, was told to replace the throttle body positioning sensor TPS.
Does anyone know the part number?? dont have a owners manual.
 

·
Premium Member
Joined
·
14,898 Posts
Does anyone know the part number?? dont have a owners manual.
You won't find the part number in the owner's manual, but you could look it up on any number of online parts vendors' Web sites, including these:

Bernardi
Cheap Honda Parts
College Hills Honda
Honda Parts Deals
Honda Parts Now
Honda Parts Store
Honda Parts Unlimited
Majestic
My Honda Parts Store
Real Honda Parts

The TPS isn't sold separately; you must replace the throttle body.




Also see:
Accessories, Care and Mods > Maintenance and Service > Throttle Position Sensor (TPS) / Throttle Body
Accessories, Care and Mods > Maintenance and Service > DIY: Clean your throttle body

As for the owner's manual, you can order a paper copy from Helm Inc. here. Online PDF version, courtesy of techinfo.honda.com, here.

Lowbrass03, please add your location to your profile.
 

·
Registered
Joined
·
1 Posts
I got the code read P2138, was told to replace the throttle body positioning sensor TPS.
Does anyone know the part number?? dont have a owners manual.
I am currently having this same exact problem with my 2008 Element. Lost all power to the gas pedal on a hill, the VSA & Engine light went on, and the vehicle idled at 20mph. Put the vehicle in park, the engine surged (lobed), and then I turned the car off. After restarting it, the VSA light went off but the engine light stayed on. Brought it to a dealer who couldn't say what it was. (He called it a computer "fart"-seriously!) It ran normally for 600 miles, and then it happened again. Brought it to a different dealer and he said that the code it was giving him didn't make sense. That the number was somewhere in between a gas pedal sensor and the throttle body sensor. Can I ask what eventually happened in your situation? Did you get a fix for your problem. My Element has been in the shop for 2 days so far....
 

·
Registered
Joined
·
1 Posts
@guitrs8 Did you ever figure out your issue? Just had the same thing happen to me and I got a P2646 code coming up with the VSA warning light . Not sure what the issue is yet but it is not looking good so far. If I give the car anything over moderate acceleration the engine cuts out.
 

·
Registered
Joined
·
1 Posts
Just wanted to chime in for future Google searchers...

This exact same thing happened to my car in Feb 2018, and has just happened again yesterday (May 2019). Engine light, VSA, and AWD lights come on, vehicle has a "surge" when accelerating around 40 mph, was able to get to 60 mph on the highway but it struggled and surged on hills. After it "surges" at 40mph, it'll do it when shifting up every gear (automatic transmission). After restart, only the check engine light is on, but the VSA/AWD lights come on after accelerating and experiencing the first "surge".

The code pulled is P2646 on my 2008 Element, which is "Rocker Arm Actuator Stuck Bank 1". The original fix was to replace the VTC Oil Control Valve (Rocker Arm Oil Pressure Switch) as well as the Variable Valve Timing (VVT) solenoid. This was per a Honda TSB found by my mechanic.

Pulling the same code now, car was brought into the shop this morning hopefully covered under the shop's warranty. I'll follow up if there's a new finding, otherwise start here if this code is pulled.
 

·
Registered
Joined
·
1 Posts
What was the outcome with your car?

Just wanted to chime in for future Google searchers...

This exact same thing happened to my car in Feb 2018, and has just happened again yesterday (May 2019). Engine light, VSA, and AWD lights come on, vehicle has a "surge" when accelerating around 40 mph, was able to get to 60 mph on the highway but it struggled and surged on hills. After it "surges" at 40mph, it'll do it when shifting up every gear (automatic transmission). After restart, only the check engine light is on, but the VSA/AWD lights come on after accelerating and experiencing the first "surge".

The code pulled is P2646 on my 2008 Element, which is "Rocker Arm Actuator Stuck Bank 1". The original fix was to replace the VTC Oil Control Valve (Rocker Arm Oil Pressure Switch) as well as the Variable Valve Timing (VVT) solenoid. This was per a Honda TSB found by my mechanic.

Pulling the same code now, car was brought into the shop this morning hopefully covered under the shop's warranty. I'll follow up if there's a new finding, otherwise start here if this code is pulled.
 

·
Premium Member
Joined
·
83 Posts
Just wanted to chime in for future Google searchers...

This exact same thing happened to my car in Feb 2018, and has just happened again yesterday (May 2019). Engine light, VSA, and AWD lights come on, vehicle has a "surge" when accelerating around 40 mph, was able to get to 60 mph on the highway but it struggled and surged on hills. After it "surges" at 40mph, it'll do it when shifting up every gear (automatic transmission). After restart, only the check engine light is on, but the VSA/AWD lights come on after accelerating and experiencing the first "surge".

The code pulled is P2646 on my 2008 Element, which is "Rocker Arm Actuator Stuck Bank 1". The original fix was to replace the VTC Oil Control Valve (Rocker Arm Oil Pressure Switch) as well as the Variable Valve Timing (VVT) solenoid. This was per a Honda TSB found by my mechanic.

Pulling the same code now, car was brought into the shop this morning hopefully covered under the shop's warranty. I'll follow up if there's a new finding, otherwise start here if this code is pulled.
Had the same problem not so long ago, keeps coming on from time to time, change those parts as well and did an oil change with a Honda oil filter, hopefully its just a case of dirty oil...
 

Attachments

·
Registered
Joined
·
1 Posts
Just wanted to chime in for future Google searchers...

This exact same thing happened to my car in Feb 2018, and has just happened again yesterday (May 2019). Engine light, VSA, and AWD lights come on, vehicle has a "surge" when accelerating around 40 mph, was able to get to 60 mph on the highway but it struggled and surged on hills. After it "surges" at 40mph, it'll do it when shifting up every gear (automatic transmission). After restart, only the check engine light is on, but the VSA/AWD lights come on after accelerating and experiencing the first "surge".

The code pulled is P2646 on my 2008 Element, which is "Rocker Arm Actuator Stuck Bank 1". The original fix was to replace the VTC Oil Control Valve (Rocker Arm Oil Pressure Switch) as well as the Variable Valve Timing (VVT) solenoid. This was per a Honda TSB found by my mechanic.

Pulling the same code now, car was brought into the shop this morning hopefully covered under the shop's warranty. I'll follow up if there's a new finding, otherwise start here if this code is pulled.
Mine did this and it started bucking at 40 mph. My mech said it needed new lifters and some other minor engine work. I am reluctantly selling it and got a new car for now and may change my mind. Its still worth a lot for 2007 and I took good care of it all these years so decisions being made soon - but love love love my Element.
 
1 - 11 of 11 Posts
Top