Honda Element Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi everyone.. So I've had my E for 2 days now and we noticed yesterday that when we are on the highway going around 65mph or more.. this odd sounding high pitch-like noise starts. it's not consistent and it comes in spurts. Kind of sounds like something is rubbing or some kind of friction is occurring if that makes any sense? Doesn't sound like it's coming from outside.. but seems like it's more towards the driver side near the steering wheel area...

It only occurs when we're on the highway going 65mph or more. There is just over 100 miles on my E. it's a 2010 EX AWD...

I talked with my friend who was also my sales guy and he said to bring it in when it gets inspected.. but I"m a bit concerned b/c the noise is driving me effing insane. It almost sounds like rubber being rubbed together for a noise..

any idea?!!:|
 

·
Moderatorium
Joined
·
6,408 Posts
Windshield trim whistle, which is a perennial E issue. Press down on the outside trim all around the windshield with the palm of your hand and see if it helps.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Windshield trim whistle, which is a perennial E issue. Press down on the outside trim all around the windshield with the palm of your hand and see if it helps.
AHh Okay! Thanks so much I will give that a shot and hopefully it goes away.. if not , any other suggestions? I was just worried something was wrong internally with the E!
 

·
Registered
Joined
·
1,037 Posts
Stuck brake caliper...?

LBD
 
1 - 4 of 4 Posts
Top