Honda Element Owners Club banner
1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 · (Edited)
So, I got my Drawtite wiring kit from etrailer. Double checked it, it says its for 2007 and later, I've got a 2007. The part in the spare tire well connected easily, no big deal. But I can't seem to figure out where the connector for the box under the steering wheel goes. It says to look for the gray 10 pin housing with blue tape (Instructions for my kit: http://www.etrailer.com/instructions.aspx?pn=118465). I found a green 44 pin housing with blue tape, but that definitely doesn't fit. And there's already a box that looks like the "Trailer Unit" that comes with the OEM wiring kit under the dash, with a 10 pin connector, though a much smaller 10 pin than the kit I bought (instructions for that kit are: http://www.handa-accessories.com/element/07hitch.pdf). I didn't think the car came wired for a trailer, though I suppose it's possible and I (and the dealer) didn't realize it (the dealer had to get it from another dealer, and there were some extras included on it that I didn't pay for that the dealer I bought it from didn't realize were there). This is the connector on the kit:

This is the green 44 pin connector that had blue tape:

This is the "Trailer Unit" looking box:

And this is the connector to the "Trailer Unit" box:


Is one of these the thing I'm supposed to plug into? Or do I have the wrong kit? Or do I already have a wiring package installed? I'm confused, thank you for your help!
 

·
Registered
Joined
·
3,645 Posts
Keep looking....it has been reported several times that the gray connector is hidden really well. Above the steering colum as I recall.

Good luck.
 

·
Registered
Joined
·
3,059 Posts
I found the connector hidden UP a bit but in plain sight. It wasn't anywhere near the steering column like everyone kept saying, but along the left wall and up a little.
 

·
Registered
Joined
·
27 Posts
:confused:I've just been through the same song and dance as the original poster. Found the green plug in the place described for the 'real' plug, but pins differed, etc.

Just found this thread this evening and went back out for the umpteenth time, found what looks like the correct gray plug. Can't get it aligned/plugged in the dark ... maybe tomorrow.

Boy, there's not a halfway decent way to lay under there and work, is there?

Anyway, I found the plug all the way to the left. Less than two inches from the left wall, about 6 to 8 inches above the hood release. The connector is right behind the little change drawer or whatever that thing is supposed to be.

There's not room or a decent angle to take a picture. The green plug is readily accessible for a photo, of course.

Now I'm wondering what the green plug is for :confused:

Will post a msg when I'm successful in doing the harness. The hitch was a breeze to install, relatively.
 

·
Registered
Joined
·
27 Posts
On our 2009 EX, the gray plug is not above the steering column. It is all the way to the left, 6-8 inches above the hood release handle. If you could yank out the little coin drawer to the left of the steering column, you'd be able to see the plug through that hole.

There's no way in h*ll to get a camera up there to take a photo.

Good luck.
 

·
Registered
Joined
·
3,645 Posts
The 2009 may (or may not) have a similar plug location as the '07 model refrenced in this thread....but it sure seems to be very similar. Thanks for the info.
 

·
Registered
Joined
·
27 Posts
TUBALEITER reports a similar location on his/her 07 EX on July 5th (above)

DESINIA reports a similar location on his/her 08 EX on July 4th (above)

Looks like maybe a trend. It's just the install instructions are seemingly out of date.
 
1 - 10 of 10 Posts
Top